I'm quite new to Blender and have been trying for days to give my character a glow effect on his eyes and arm, and i have been using three textures for this, but it seems I can only keep two of these textures activated at a time. So at the moment it seems like i have to choose between bump and textured,

enter image description here

or flat textured and glowing.

enter image description here

Here are the textures I'm trying to use:

enter image description here enter image description here enter image description here

I'm sure there is a obvious way to solve this but i can't see it and no tutorial i have watched has brought me any closer to an answer.

How do I solve this?

My node setup is a mess as I began this week to learn about it.

enter image description here

  • $\begingroup$ Hello and welcome to BSE! Could you provide some picture of you node setting? Or upload the blend file using this link blend-exchange.giantcowfilms.com ? That may help to understand your issue $\endgroup$ – lemon Aug 25 '19 at 16:14
  • $\begingroup$ I will update my post to show my node setup. $\endgroup$ – FrostBird Aug 25 '19 at 16:21
  • $\begingroup$ Hard to say, what you want to do with this setting. Only the selected output will be rendered. For the other aspect, the emissive texture should be to emission. $\endgroup$ – lemon Aug 25 '19 at 17:49
  • $\begingroup$ Ok, thanks. I am extremely new to this. But when i connect emission to emission, the whole model turns pink. But if I remove the emission and connect the texture image to the principal BSDF emmision, i get the textures to overlap perfectly, but with no glow effect or a way to control glow strength. $\endgroup$ – FrostBird Aug 25 '19 at 18:21
  • $\begingroup$ FrostBird, I've tried the textures linked in your question on a flat plane model. This could be insignificant (image format, etc.). The best is to upload your model including (packing) the textures with it as a blend file. Maybe someone here could help on this basis. $\endgroup$ – lemon Aug 25 '19 at 18:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.