2
$\begingroup$

I'm following this tutorial on YouTube: https://www.youtube.com/watch?v=5NlvgMYZgaY&list=PLJtehCu4iIj4T0dqawwRolg8B6DPzmu01&index=46&t=0s

The problem is that the character he is using is a single colour so when he applies the new UV map and texture there is no issue, however my character's texture is not one colour. I want to be able to add the 2D eyes for animation while being transparent and showing the original texture underneath. The picture below shows the texture and the eyes are 3D before I decided to animate them in 2D.

Does anyone know how I can animate the texture as a transparent texture so I can maintain the texture beneath?enter image description here

$\endgroup$
  • $\begingroup$ First: looks great! Next, can you please provide screenshots of your node setup, the sprite map (texture used for facial animation) and a render(s) of the unwanted result(s)? It would be even better if you could upload your .blend file but I understand if you feel protective of your work $\endgroup$ – hatinacat2000 Aug 25 at 13:14
  • $\begingroup$ Thank you, that's very kind of you. I'm happy to upload the file, heres the link: drive.google.com/file/d/1ToHs8IzFSawYS1ubySUXi7AJN9TxuGZO/… $\endgroup$ – BlackenedPhoenix Aug 25 at 13:24
  • $\begingroup$ Really quick: Did you remember to hook up the alpha channel of the texture to the fac setting of the Mix shader? $\endgroup$ – hatinacat2000 Aug 25 at 13:26
  • $\begingroup$ No I got stuck at the part of the tutorial where he unwraps and creates a new UV map and then creates a copy of the texture to apply to the new area, the texture comes out strange because its not a single colour like the lego head. I will add the nodes in now and see if it fixes anything, thank you. $\endgroup$ – BlackenedPhoenix Aug 25 at 13:31
  • $\begingroup$ which version of Blender did you make this with? I am using 2.8 $\endgroup$ – hatinacat2000 Aug 25 at 13:32
1
$\begingroup$

Your problem is that the UVs for the face got moved away from the skin material. Further, the skin material is separate from the eye material, which is ok if you are following the tutorial, but note that he superimposes the eye material onto the skin material with the Mix Shader node. You only have 1 UV map--this makes it so the eyes will never be in the right place; they will always be floating out in space, away from the skin texture. We can fix that.I will record a gif or something, hang on...

...do you have a version of the file with the eye region still attached to the mesh? We should start from there. Please upload that file. Use https://blend-exchange.giantcowfilms.com/


enter image description here

Oh! I can just attach the animation :j

enter image description here

enter image description here

enter image description here

enter image description here

enter image description here

enter image description here

enter image description here

...animating the new UV map "_EyesUV" will not have any effect on the body texture now. Here is the .blend file:

NOTE: if you are no longer satisfied with your textures, there are a couple of solutions:

  1. Export your UV layout for the eyes in the UV editor (I suspect you already know how to do this) and warp the eye textures you already have into proper orientation in Photoshop.
  2. paint directly onto the model in Blender (see any quick-and-dirty Youtube tutorial for that). I find this technique expecially useful for high-contrast texture features I know will look warped if I try to eyeball it in Photoshop.

ALSO, IMPORTANT: Texture will be warped until you de-parent armature. I do not know yet why the armature was an issue.

I deparented the armature, recalculated the bone rolls, reset the pose, and re-parented, and it works now:

Baking the Eyes object silhouette onto an image using the Body's Ambient Occlusion.

enter image description here enter image description here enter image description here The "Collections" panel replaces the "Outliner" panel in Blender 2.8. You can find these same options there: enter image description here enter image description here If the bake takes longer than you (I) thought, it's because the second UV map also has coordinates for the rest of the body (not sure how to remove those for the bake, maybe just drag them outside the UV canvas?). Save this image: enter image description here

File:

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.