0
$\begingroup$

I use a node group (see linked blend files) along with extremely limited numbers of bounces & lighting to achieve a certain non-photorealistic effect in cycles. This effect has previously resulted in renders that have zero noise and only solid blocks of color. However, any file I create with blender version 2.8 (see version output below) results in noise when using identical settings to the files created in pre-2.8. The pre-2.8 files perform as expected when rendered in 2.8. I suspect that there may be some setting that was set in 2.7 that isn't being set in 2.8's file initialization but I'm unsure how to confirm or deny that.

$ blender --version
Blender 2.80 (sub 75)
        build date: 2019-07-30
        build time: 16:57:38
        build commit date: 2019-07-29
        build commit time: 14:47
        build hash: f6cb5f54494e
        build platform: Linux
        build type: Release
        build c flags:  -Wall -Wcast-align -Werror=implicit-function-declaration -Werror=return-type -Werror=vla -Wstrict-prototypes -Wmissing-prototypes -Wno-char-subscripts -Wno-unknown-pragmas -Wpointer-arith -Wunused-parameter -Wwrite-strings -Wlogical-op -Wundef -Winit-self -Wnonnull -Wmissing-include-dirs -Wno-div-by-zero -Wtype-limits -Wformat-signedness -Wrestrict -Wuninitialized -Wredundant-decls -Wshadow -Wno-error=unused-but-set-variable -Wimplicit-fallthrough=5 -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -fuse-ld=gold -fopenmp -std=gnu11   -msse -pipe -fPIC -funsigned-char -fno-strict-aliasing -msse2
        build c++ flags:  -Wredundant-decls -Wall -Wno-invalid-offsetof -Wno-sign-compare -Wlogical-op -Winit-self -Wmissing-include-dirs -Wno-div-by-zero -Wtype-limits -Werror=return-type -Werror=implicit-function-declaration -Wno-char-subscripts -Wno-unknown-pragmas -Wpointer-arith -Wunused-parameter -Wwrite-strings -Wundef -Wformat-signedness -Wrestrict -Wuninitialized -Wundef -Wmissing-declarations -Wimplicit-fallthrough=5 -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -fuse-ld=gold -fopenmp -std=c++11   -msse -pipe -fPIC -funsigned-char -fno-strict-aliasing -msse2
        build link flags:  -Wl,--version-script='/build/blender/src/blender-2.80/source/creator/blender.map'
        build system: CMake

This is what it looks like when rendered with 2.8 in a file created pre-2.8: The top of suzzanne lit from above

And this is what it looks like when rendered in 2.8 with a file created with 2.8: The same image as above but noisier

The difference is very minor, but is there, as demonstrated by using a flood fill with a threshold of 0 via GIMP on various parts of each image:

Pre-2.8 file: The same image as above with several solid regions of color shaded black

Post-2.8 file:enter image description here

A pre-2.8 file:

A post-2.8 file:

My system information (generated with inxi -b):

System:    Host: ganymede Kernel: 4.19.66-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.16.4 Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: Micro-Star model: X470 GAMING PLUS (MS-7B79) v: 2.0 serial: <root required> 
           UEFI [Legacy]: American Megatrends v: A.B0 date: 07/04/2019 
CPU:       8-Core: AMD Ryzen 7 2700X type: MT MCP speed: 2160 MHz min/max: 2200/3700 MHz 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] driver: amdgpu 
           v: kernel 
           Display: x11 server: X.Org 1.20.5 driver: amdgpu FAILED: ati unloaded: modesetting 
           resolution: 1920x1080~60Hz, 1920x1080~60Hz 
           OpenGL: renderer: Radeon RX 580 Series (POLARIS10 DRM 3.27.0 4.19.66-1-MANJARO LLVM 8.0.1) v: 4.5 Mesa 19.1.4 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8168 
Drives:    Local Storage: total: 1.84 TiB used: 818.81 GiB (43.4%) 
Info:      Processes: 481 Uptime: 2d 1h 55m Memory: 31.42 GiB used: 16.30 GiB (51.9%) Shell: bash inxi: 3.0.35

Edit 2019-08-27:

It appears that this pixelated noise is happening regardless of what material I use. A simple node group of a noise texture fed through a colorramp on constant going to an emission shader, assigned to a flat plane demonstrates this very effectively. I've increased the contrast to highlight the noise in the midtone regions, though this has crushed out the noise in the black and white regions.noise separated into 3 distinct levels of value, with the midtone being composed of noise.

This has happened in PNG, JPEG, Targa, and TIFF export formats.

Curiously, this noise is notably absent on transparent sections of the render (as set in the film settings in the render panel). the same noise pattern, with the black regions being replaced with full alpha transparency

$\endgroup$
0
$\begingroup$

It turns out it's the dithering setting under Properties -> Output -> Post Processing -> Dither. Setting this to 0 from the default(?) of 1 appears to completely fix this issue.

Properties -> Output -> Post Processing -> Dither

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.