2
$\begingroup$

I added a background image with ADD>IMAGE>BACKGROUND The image appears in viewport but when I hit F12 to render, it does not show up. What did I do wrong?

$\endgroup$
  • $\begingroup$ Background images are for reference only, the aren't supposed to show in renders. The add-on Image as Planes may be what you're looking for. $\endgroup$ – Robert Gützkow Aug 25 at 0:00
2
$\begingroup$

The Reference and Background images actually insert viewport-only Empties, with images referenced on them. This feature is primarily for displaying blueprints or plans, reference items used during modelling, not intended for final render.

What you're looking for is to add an actual mesh plane into your scene, and texture map it with an image. That's such a common operation, there is a built in script to do it. I do not know why it isn't enabled by default when you install Blender. To enable it:

  • Go into Edit > Preferences, then Addons on the left-hand column.
  • In the search field type 'images'. You'll see "Import-Export: Import Images as Planes" appear.
  • Enable the checkbox next to the addon's name.
  • Close the Preferences window.

A new third image option will now appear: Add > Image > Images as Planes.

This script opens one or multiple images at once, properly adds and proportions a plane for each, and adds correct texture, material and UV settings. That's what you'd need to do, end-to-end, to have a "real" image in the scene that shows up during render.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.