0
$\begingroup$

As the title says, my .obj file that I want to import into Blender does not show up at all after hitting "File" - "Import" - "Wavefront .obj" as if it doesn't exist.

It definitely exists in the correct folder as I can open it in File Explorer and I've tried dragging it into Blender with no luck. I've also tried a .ply version of the same file but it doesn't show up in Blender's search window either.

The weird part is that I've already imported nearly a dozen other .obj files from the same folder that are all exports from MagicaVoxel (Just like the new file I'm trying to import) with no issues at all. Those files all show up perfectly fine in the Import window but my new files don't.

Trying to import into a new, blank blender file doesn't work and trying to open that file directly with Blender even causes Blender to CTD with no error message.

What's the deal here?

$\endgroup$
  • 1
    $\begingroup$ Does the file have the .obj extension? Blender filters by extension for what it displays in the file browser. Can you share the obj file? $\endgroup$ – rjg Aug 24 at 19:44
  • $\begingroup$ Yea, like I said, it shows up perfectly fine in File Explorer and it's in the same exact folder as all of the other .obj MagicaVoxel exports, but Blender doesn't show it like it does the others for some reason. Weird update: While trying to upload the file to Google Drive so that I can share it with you, it didn't show up in that explorer either. I guess somehow MagicaVoxel is suddenly exporting corrupted files that only show up in Windows File Explorer but can't be opened anywhere else... $\endgroup$ – Grant Pisani Aug 24 at 19:57
  • 1
    $\begingroup$ Obj is basically just a text-file so try to open it in any text editor and you'll see that's most likely not any blender issue. $\endgroup$ – brockmann Aug 24 at 20:07
0
$\begingroup$

Dragging it into Blender won't help, as Blender's drag and drop handling doesn't auto-check the file type and apply the relevant importer (unfortunately!).

It's possible that when you select Import > Wavefront (.obj) the file is being filtered out of the view for some name-based reason. You can disable filtering in the top right corner to view all files without extension filtering.

enter image description here

If none of that works and the importer is having some problem with the actual file, you'll get some sort of error message in the system console. But it doesn't sound like you've got that far yet.

"trying to open that file directly with Blender even causes Blender to CTD with no error message." That one would be a bug, then. It should be able to notice that you're trying to use Open on something that's not a .blend file and not crash, but it seems you have discovered a case where that isn't happening.

$\endgroup$
  • $\begingroup$ further thought: is the problematic file different from the others in any other noticeable way? Is it particularly large, or anything like that? $\endgroup$ – acro Aug 24 at 20:01
  • $\begingroup$ The file filtering was one of the first things I checked and the file size was actually the first idea I had as well. Unfortunately, there is no filter and there are multiple other files that I've already been able to import before that are the same size or bigger than this new file. Even so, I tried making a test file that was only 3kbs but even that didnt' show up $\endgroup$ – Grant Pisani Aug 24 at 20:12
  • $\begingroup$ Update: Apparently this export folder somehow ended up duplicated on my pc on a separate drive. I was looking in that duplicated folder that isn't connected to MagicaVoxel, so new files did not export there. Problem is, even after finding the file in question, Blender won't import it. After selecting the file and then hitting, "import," Blender hangs for a few seconds but nothing is imported. No new assets are added to the outliner, no error messages are displayed, and no hint as to why the file won't import $\endgroup$ – Grant Pisani Aug 24 at 20:13
  • 1
    $\begingroup$ 'hangs for a few seconds' sounds like the importer did do something there. Is it definitely not reporting any activity in the system console? If that's not visible, you can open it with Window > Toggle System Console. Beyond that - check if it created any new objects in the scene but maybe didn't populate them with verts. Then... can you upload/share the file somewhere? Other things to try include re-running the importer with different options. Hard to say what's going wrong without error feedback $\endgroup$ – acro Aug 24 at 20:32
  • $\begingroup$ Thanks for all the help. Turns out it did import, but for some reason had it scaled so far down that you couldn't even see it. It also stuck it in an arbitrary Outliner collection instead of in the main hierarchy so I didn't see it. $\endgroup$ – Grant Pisani Aug 24 at 20:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.