I am trying to render the albedo of a mesh with a material, I have managed to get a flat render without lights and shadows by using the diffuse color passe, but the color are not the same as the one used in the material of the mesh.

Here is my setup:

  • 3D view: A sphere (here you can see his material thanks to the viewport shading set to material) and a light (to test if there are shadows in the renderenter image description here

  • UV / Image:
    Each face of the sphere is unwrapped on that square with two color enter image description here

  • Shader node:enter image description here

  • Render layer: the passes I have checked enter image description here

  • Compositing node: enter image description here

  • Result:
    As you can see the color are not the same as the one of the UV/Image enter image description here

Here is a comparison between the color of the image I have used to texture the mesh (on the left) and the color I get from the diffuse color passe (on the right)enter image description here

Does someone know how to fix that problem or why the color shift ?

  • $\begingroup$ I'm voting to close this question as unclear, because (1) I can't reproduce it and (2) the last to images don't seem to relate. I'd suggest you reproduce the problem in a minimal working example and upload that file here. $\endgroup$
    – Leander
    Commented Aug 24, 2019 at 12:13
  • $\begingroup$ Here I have edited my question and made my exemple simpler, I hope it is now easier to understand my problem. As I see in your comment Leander, your diffuse color is the same as the one of the checker texture. I don't understand why I have a difference. @Leander $\endgroup$ Commented Aug 24, 2019 at 15:33
  • 1
    $\begingroup$ I have experienced this disparity as well and am not certain of the cause. I see that the color space for your texture node (third image) is "Linear" (typical setting). Check if your render settings, i.e. the color space, is something unexpected. By default it should be Filmic. This may desaturate colors slightly. Try changing that, just for the bake. $\endgroup$ Commented Aug 24, 2019 at 15:41
  • $\begingroup$ really, instead of voting to close every question we don't understand, we should just ask for more info in the comments, or wait for someone else who might be able to help. $\endgroup$
    – Millard
    Commented Aug 24, 2019 at 16:18
  • 1
    $\begingroup$ @Millard - this is exactly what a close vote is. There are many cases on BSE where people drop in, ask some vague question, then leave if nobody answers within 10 minutes. The close vote is a heads-up to people. If the question gets improved and gathers enough attention, it can also be reopened. $\endgroup$ Commented Aug 25, 2019 at 14:11

1 Answer 1


As Leander show in the picture of his comment there shouldn't be a problem with the passes or the nodes I have used and how I have connected them.

As hatinacat2000 suggest, I get better result by setting the color space to linear

enter image description here

Here is the texture on the left and the render of the albedo on the right a bit better but not the same:

enter image description here

In fact the color of the albedo where shifted because of the High contrast setting (in the Look of the color Management), by changing it to none The color of the albedo are the same as the one of the texture

enter image description here

enter image description here


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .