3
$\begingroup$

I have been using Lynda.com to learn character modeling. However, I have been unable to find a comprehensive guide to UV mapping. Because of this, I've had to figure it out using various bits of different tutorials online, and I've had some good success. However, I recently came across a problem that has halted my progress completely.

When applying textures using UV mapping, these strange gaps started appearing only on the hands of the character, everywhere else looks fine. If anyone could tell me what's going on, I would greatly appreciate it.
edit mode edit mode
object mode object mode

$\endgroup$
  • $\begingroup$ I've been trying to work through all the suggestions so far but no dice. After shrinking the UV map for the hands deeper into a blackened area of the texture I'm using, it appears that these gaps are not colored "white" from another part of the texture I'm using, but are just places where the color isn't able to be applied for some reason. I may be new to blender but this still seems completely bizarre. Also, that uncolored area between the legs is just an area I haven't gotten to yet, so there's no problem there. $\endgroup$ – Jim Aug 14 '14 at 2:35
  • $\begingroup$ ANSWER: I ended up just using blender's texture painting to directly paint over that stubborn part of the hands. I still have no idea why my UV map alone didn't work, but regardless, I found a way to get color into those areas. Thanks for all the help! $\endgroup$ – Jim Aug 14 '14 at 3:22
  • $\begingroup$ Check alpha within the texture image as well, sometimes alpha areas can cause "grey" issues on edges. $\endgroup$ – MRMR May 23 at 9:41
1
$\begingroup$

It looks to me that certain marked edges get altered with your Multires/Catmull-Clark modifier: the "new" faces created by that seem to be misplaced to the white areas of the texture that you are using.

I would suggest that first you check for the split edges. I might be terribly wrong, but it looks like you have them on your sleeve... and body too.

It's very easy to miss and set *Mark Sharp" instead of Mark Seam, for instance, and then as you set multires or subsurf modifiers, edges marked sharp are getting split, which, among other things, means that integrity of the UV is violated.

Also kindly check doubles (Edit Mode > W > Remove Doubles).

I would also suggest that after you have done it you could try applying your multires modifier for testing purposes and check the exact position of UV for the "white" faces on the hands. Blender now allows both selecting faces in the 3D Viewport and seeing them on your UV in the UV/Image editor, but vice versa too. There is a button "Keep UV and edit mode mesh selection in sync".

Hopefully this would help.

$\endgroup$
  • $\begingroup$ I would also, try deactivating "Sub-Divide UV's" in the modifier panel. Sometimes it's better on, sometimes it's better to have it off depending on the geometry. $\endgroup$ – MarcClintDion Aug 12 '14 at 20:59
1
$\begingroup$

As a child we are taught to colour-in and always stay within the lines. With uv textures the opposite is the best option. When a texture colour stops right at the edge of the uv layout it can sometimes get the colour from the other side of the line which can leave a small line at the edge of the face on your model. When using a subdivide smooth method this small line can be expanded, which is what you are seeing here.

The solution is to bleed the texture over the edges so that you don't get the white background onto your model. Usually two or three pixels over is enough.

As you appear to be using an existing image for the texture you may want to move the uv's away from the edge a little so the face edges aren't right next to the white.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.