0
$\begingroup$

Working on a design going to a CNC router. The CNC router can use dxf so I export to dxf. However, when I import into AutoCAD to test, the scale is way off. The CNC shop confirmed this on their machine too.

How I can preserve the scale when exporting to AutoCAD?

Object in blender (60.4cm) enter image description here

Same length in AutoCAD is (450.0021 unknown units): enter image description here

I wish I could just stay within blender but unfortunately I have to interface with proprietary software running on CNC machines.

$\endgroup$
1
$\begingroup$

There are a few things to check and keep in mind when exporting to other software. I don't know if this will help your specific issue.

1) Make sure your objects all have their scale applied (scale should show as 1:1:1 in info panel) before exporting. You may also need to apply rotations in some cases.

2) Changing the units in blender generally wont be preserved when exported. When you need to preserve the size in an external program, prior to 2.8 I would recommend setting Unit System to none. In 2.8 just leaving it in the default metric units also seems to be fine. In either case you are working under the premise that 1 Blender Unit is equal to 1 Meter.

enter image description here

If you want to work with a more convenient unit size, for example if you wanted to use CM or MM instead of Meters. You would have to also change your Unit Scale setting to match. So if you changed Length to CM, you would need to change Unit Scale to 0.1. This works fine when exporting to things like Stl.

3) Finally there are the export settings, which usually the defaults of are fine. But you may need to change things for your specific target, especially when you are exporting to a proprietary format which is then going to be read by something which isn't the editor of that format. The AutoCAD exporter settings are going to be aimed at making a file that AutoCAD will edit, which may not be exactly what the CNC software expects.

|improve this answer|||||
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.