3
$\begingroup$

After creating several group instances, I've found that the original objects I used in their creation will show up during a render.

I thought I could fix this by selecting the original objects, going to the Object context, and under Visibility, deselect Show in Renders. However, while this does stop the object from being rendered, it also stops every other grouped object of its kind from being rendered as well.

How can I hide these original objects, while keeping their group instances visible?

Version 2.8

$\endgroup$
5
  • $\begingroup$ I'm not very familiar yet with the 2.8's Outliner, but I think it's not called groups anymore, only collections. Also, if you uncheck the Exclude From View Layer box of the original collection, it won't appear in the render, so you'll get what you want... $\endgroup$
    – moonboots
    Aug 22, 2019 at 8:54
  • $\begingroup$ Yeah, I'm still getting used to the 2.8 interface. I haven't found the Exclude option, but what I've tried to do is to move the original assets into a separate collection, so I have a Main collection for rendering, and an Assets collection for things to be grouped. I can then disable them from being visible. However, I get this odd clutter in my outliner. The assets are shown in their new collection, but they are also still present in the main collection, and the lines connecting them in the hierarchy tree are dashed instead of solid. $\endgroup$
    – hiigaran
    Aug 22, 2019 at 13:32
  • 1
    $\begingroup$ the Exclude option is the box that you tick, it works fine if you use this method: zupimages.net/up/19/34/jnh7.jpg $\endgroup$
    – moonboots
    Aug 22, 2019 at 13:34
  • $\begingroup$ actually even in 2.79 I didn't use group instances, linked-duplications are much more convenient in my opinion, but you may have reasons to use group instances? $\endgroup$
    – moonboots
    Aug 22, 2019 at 13:40
  • $\begingroup$ Linked duplications increase the number of vertices etc. @LeClerical_Error's answer below does the trick. $\endgroup$
    – Vincent
    Dec 16, 2021 at 13:08

1 Answer 1

7
$\begingroup$

there's actually a pretty simple workaround for this. All you need to do is put your collection into a collection, and make the highest collection non-rendered while keeping the baseline set to renderable

enter image description here

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .