0
$\begingroup$

[EDIT] I figured out the issue. My file management setup in the outliner was pretty terrible, there were random collections that messed with what the project rendered. I just moved all the meshes into a single collection and the render looks as it's supposed to.

I looked up in forums to find the issue but I didn't see any solutions that could help me, so I decided to post it here.

For some reason whenever I try rendering my image, almost all the objects disappear, and I don't know what could be causing it.

  • none of my objects are hidden
  • rendering is not restricted on any of the objects
  • in the final render the camera is for some reason panned in further than what shows in the workspace and only showing one washing machine mesh and one plane, no other object
  • the final render doesn't keep the mesh of the object, looks more like a cube in place of the washing machine
  • tried adding in a new untampered cube next to the mesh, the cube didn't appear in the final render
  • I have rendered other projects today and they look perfectly fine
  • I have moved and rotated the camera and rendered the image, the render has a changed position and rotation but stays panned in
  • I tried deleting and creating a new camera and still, nothing changed
  • I switched around materials to see if the materials were what caused the issue, no materials keep the final render from showing meshes

I did not change the camera position or rotation in any of these shots:

enter image description here

enter image description here

enter image description here

my .blend file here: https://filebin.net/nxtlkyqpb9dgulcb

I'm new to Blender still, so I am beyond confused. Please help!

$\endgroup$
  • 1
    $\begingroup$ Haven't had time to look at your file, but it seems like you have big cube in the collection that is hidden in the viewport. If you haven't activated the restriction toggle for rendering as well, it will show up in the render. blender.stackexchange.com/questions/141144/… $\endgroup$ – Robert Gützkow Aug 21 at 7:37
  • 2
    $\begingroup$ What @rjg said. Did you by chance add a big cube, perhaps as a domain for volumetric lighting? Turning off visibility in the viewport (the little eye in the outliner in the top right) will not turn off visibility for render. For some reason, Blender 2.8 now hides the render visibility switch from you by default. You can turn it on using the little filter button at the top of the outliner. $\endgroup$ – Lewis Aug 21 at 10:04
  • $\begingroup$ @Martin Z - Blender should have these options enabled by default, but it doesn't. Like Lewis and rjg are saying, click that filter-looking icon in the upper right, in the Collections panel, and enable the 2 icons that look like a screen and a camera. The screen is another icon that acts similarly to the eye, hiding objects in the viewport when off. When the camera icon is off, that object is not rendered. That should take care of it but if it does not, try clicking on the orange square tab on the right side of the screen ("Object" menu). From there, under "Visibility", make renderable $\endgroup$ – hatinacat2000 Aug 21 at 12:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.