6
$\begingroup$

I am doing a render of a tutorial I finished, and when I go compositing it I get a weird jitter on a defocused object. The tutorial had this too (at 1:04:00), but I wonder if it is possible to remove it. I tried adding a blur/defocus node but it ended messing up with the map value.

This is the jitter I'm talking about:

Node setup

And this is my node setup:

Node setup

$\endgroup$
  • 1
    $\begingroup$ Just raise your samples. $\endgroup$ – GiantCowFilms Aug 11 '14 at 22:46
  • 1
    $\begingroup$ Try raising them and see what happens... $\endgroup$ – GiantCowFilms Aug 11 '14 at 22:56
  • 1
    $\begingroup$ Also, are you using render DOF? $\endgroup$ – GiantCowFilms Aug 11 '14 at 22:56
  • 1
    $\begingroup$ Are you using cycles or BI? Could you link to the tutorial in question? $\endgroup$ – gandalf3 Aug 12 '14 at 0:39
  • 1
    $\begingroup$ try increasing your F-Stop value $\endgroup$ – G.Rassovsky Aug 12 '14 at 14:57
6
$\begingroup$

It seems the Z always gets only one sample, so it's always noisy around defocused objects regardless of the number of scene samples. However using the mist pass (which was added since that tutorial was made) instead of the Z gives a better result:

enter image description here

To define the distance/thickness of the mist, enable the mist display in the camera settings so that you can see a visualization in the 3D view:

enter image description here

Then adjust the start and depth of the mist in world settings:

enter image description here

$\endgroup$
  • $\begingroup$ Yes, this is exactly what I wanted! Thanks a lot! $\endgroup$ – Gus Aug 12 '14 at 18:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.