1
$\begingroup$

This question already has an answer here:

I made a scene of two wine glasses on a flat surface, with an overhead light source. For some reason, when I'm viewing the objects as solids, there are strange shading artifacts that appear on all the objects. The planes do not always show the issue; you can see on the perspective on the left, the overhead plane looks normal, but in the perspective on the right it's entirely black (side note, it's an emission plane). These shadows do not appear in other object viewing modes (wire frame, materials). I'm running Blender 2.71 on a MacBook Pro with OSX Mavericks. This is my home computer, and at my work computer, which runs Windows XP, I don't have this issue ever. I'm very new to Blender, so it may be a simple fix, but I don't understand the program enough to understand what's happening and where to look to make the fix. Any suggestions would be greatly appreciated!

strange shadows

$\endgroup$

marked as duplicate by gandalf3, iKlsR Aug 12 '14 at 1:17

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • $\begingroup$ It looks like a normals issue, but if the same file works fine on another computer, then it sounds more like a hardware/platform specific bug. $\endgroup$ – gandalf3 Aug 11 '14 at 20:19
  • $\begingroup$ I haven't tried the same file on my work computer, that might be a good way to check though, thanks! $\endgroup$ – grrothman Aug 12 '14 at 0:00
1
$\begingroup$

There are 2 possible reasons:

Flipped normals The repair of this is simple: select "bad" object, enter edit mode, press tab, and select all vertex A and recalculate normals, ctrl N.

Something bad in options The easiest repair is just wipe the options. (file -> load factory settings)

$\endgroup$
  • $\begingroup$ The normals repair fixed it, thanks! Is there a way to make sure this doesn't happen again in the future? Like a default option to set or something? $\endgroup$ – grrothman Aug 12 '14 at 0:04
  • $\begingroup$ @grrothman Nope, this occurs in all 3d, as long as you manipulate mesh data, there exists the chance that faces and normals will get flipped etc. You should incorporate Ctrl + N into your workflow. (something I do as often as saving). See the answers on the duplicate post for more info. $\endgroup$ – iKlsR Aug 12 '14 at 1:19

Not the answer you're looking for? Browse other questions tagged or ask your own question.