2
$\begingroup$

I'm a total noob - and I'm doing a soft body simulation - just a ball bouncing. The ball does bounce, but it is not actually touching the collision surface, it is bouncing slightly above. It's like there's an invisible surface holding the ball floating in space. It's very noticeable in a side view (see picture). How do I make the ball actually bounce on the correct surface? enter image description here

$\endgroup$
  • $\begingroup$ In the Context Tab for Scene, icon of a Cone, glass sphere and small sphere, you can set the parameters of the Rigid body world. Increasing the "Steps per second" and "Solver iterations" will improve the accuracy of your simulation but will take longer to run. $\endgroup$ – rob Aug 20 at 18:54
  • $\begingroup$ Hi Rob, thanks for the response. Okay, so I gave that a try, and it doesn't seem to change the position of the ball. I built another version with identical settings, and that seems to work fine, so I'm not sure why I'm getting inconsistent results. I am just learning, and perhaps there is some subtle thing I'm doing wrong $\endgroup$ – JoeGideon Aug 20 at 22:25
1
$\begingroup$

Found the solution! The ball was a cube with a subdivision surface modifier, smooth shaded. The problem was that I did not hit "apply" in the modifier settings. Blender was showing me a nice smooth ball, but was animating it as though it was still a cube -- and held on to it's invisible cube geometry. Problem instantly vanishes by hitting "apply."

Thanks everybody!

$\endgroup$
  • $\begingroup$ I guess that by "Accept" you actually mean "Apply". $\endgroup$ – Fantômas Sep 8 at 11:34
  • $\begingroup$ Yes, "Apply" - sorry $\endgroup$ – JoeGideon Sep 9 at 15:44
  • $\begingroup$ You'd probably fix all by just applying the Scale, Location and Rotation (Ctrl+A), leaving your modifiers intact (it's always BAD to apply your modifiers, because you're now not anymore able to change the settings - it's RARELY required to apply just one or two - and in the correct order) $\endgroup$ – Fantômas Sep 9 at 17:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.