0
$\begingroup$

I've spent several days trying to figure out why Blender can't find my GPU in both of my workstations. On one, I have Quadro 4000. On the other, is Quadro 2000M.

One year ago I was able to install a special CUDA build from Graphic all and that version found my GPU for some reason. That version is now deleted from my PC, but none of the official builds of Blender show my GPU which is totally weird because there is nothing wrong with my hardware. It feels such a waste of time digging for secondary builds on Graphic all when I know my hardware deserves better and I simply cannot understand why Blender refuses to find my perfectly fine equipment. (HP Z Workstation 420) plus another Z workstation laptop, on none of them finds Blender my GPU but Blender works fine on my CPU.

I have the latest Nvidia Quadro drivers for my graphic cards plus CUDA toolkit installed and all of this is perfectly healthy and running outside of Blender. Blender simply cannot see my existing CUDA stuff, visible in Nvidia Control panel.

My GPUs are not visible in ANY build of Blender (2.79 Official Stable Newest, 2.8 Official) I've installed so far, as I mentioned only was visible/usable (the GPU) in that single rare GraphicAll one (build) which I can't even find anymore. Forgot what to search/Google for.

Any tips would be super amazing. Thanks

(Update: I was able to install 2.79b and it finds my GPU but it would still be nice to be able to use GPU on 2.8 which is still Mission Impossible for me) :/ // Daniel

$\endgroup$
  • $\begingroup$ Did you do anything differently that 2.79b suddenly works now? You say that you have the latest drivers installed, did you check this on the official driver dowload website by Nvidia (nvidia.com/Download/index.aspx)? $\endgroup$ – Robert Gützkow Aug 19 at 22:30
  • $\begingroup$ I didn't do something differently, it just worked. -- With the latest Nvidia drivers, and with latest drivers Eevee worked fine, but I've discovered my system works better with the Official HP 2013 Nvidia drivers from HP's site, because now Blender 2.8 can see my CUDA device (according to the debug log created).. But now after installed HP's Nvidia graphics driver I can't start 2.8, it crashes. $\endgroup$ – Daniel Ölund Aug 20 at 8:23
  • $\begingroup$ Did you find a solution? Considering a M1000M $\endgroup$ – atomicbezierslinger Oct 17 at 19:35
0
$\begingroup$

The Quadro 4000 supports CUDA compute capability v2.0 as seen here https://en.wikipedia.org/wiki/Nvidia_Quadro#Quadro

Blender 2.79 supports NVIDIA cards with CUDA compute capability v2.0-v6.1 as seen here https://docs.blender.org/manual/en/2.79/render/cycles/gpu_rendering.html#cuda

Blender 2.8 supports NVIDIA cards with CUDA compute capability v3.0 onwards as seen here https://docs.blender.org/manual/en/2.80/render/cycles/gpu_rendering.html#nvidia-cuda

I believe the latest CUDA toolkit to still include support for the Quadro 4000 is v8.0 GA2 which can be found here https://developer.nvidia.com/cuda-toolkit-archive
or here https://developer.nvidia.com/cuda-80-ga2-download-archive

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.