2
$\begingroup$

Basically what I want to do is scale a skeleton down. The reason for this is that I'm ripping a model from another game and I want to use it in Unity. When the model is ripped from the other game, it is way too big for unity and has to be scaled down in order for it to even show up on the screen.

This is my model. It has a walking animation.

enter image description here

Now I want to scale the model down from it's original scale to 0.2 by 0.2 by 0.2, I scale the skeleton down so that the mesh goes with it. enter image description here

Now I'll have to apply the scaling, so that it's the smaller scale is the default one, instead of the big one. enter image description here

As soon as I apply it, the model moves away from it's original location, and the animation is all messed up, it goes much faster to it's walking destination because he's smaller. enter image description here How do I avoid the skeleton, and most importantly, the animation from messing all up?

$\endgroup$
  • $\begingroup$ the model looks great. :D $\endgroup$ – Millard Aug 26 at 19:40
0
$\begingroup$

You can remove separately the scale keys in the dopesheet.This will allow you to scale it down.

enter image description here

$\endgroup$
2
+25
$\begingroup$

When exporting from Blender, calculate the size as 100 percent and export it, eg fbx scale 0.01 or 0.1 This is fixed in ue4.

$\endgroup$
1
$\begingroup$

If you really do not want to scale the model while exporting (or while importing into a game engine), your best bet is to scale all the fcurves on the y axis by the same factor as the previous scale, with the 2d cursor (which should be at 0,0) as the pivot point in the fcurve editor. This should keep the speed constant, but if you wanted to speed up or slow down the animation, scaling on the x axis would do that.

See, for example, before: And after:

Unfortunately, for particularly complicated animations this can be a tedious process, as you'd have to make sure that the pivot point for each scaling operation in the fcurve editor looks ok afterwards.

Another partial option is to export your animation as an FBX file and using the included scale factor during the export. Make sure to use y-forward and z-up! After exporting it, you can import it back in (crucially with the settings "Ignore Leaf Bones" and "Automatic Bone Orientation" checked!). This does not seem to apply the scale of the rig, however, and may not be worth it as such.

$\endgroup$
0
$\begingroup$

You might be better of scaling the model in Unity (and leave it at full scale in Blender).

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.