I would like to make it so that '5' toggles between edit mode and object mode instead of pressing 'Tab'. I thought I could do this via Preferences->Keymap, but when I change the shortcut to '5' in the keymap it only goes one way (for instance edit to object) but it does not toggle back and forth. What am I missing? Do I need to create a custom operator just for this?


1 Answer 1


Go into Preferences > Keymap and in search type "mode"

Go down to Object Non-modal

Turn off Mode by clicking the tick

Then go to Set Object Mode

Click on tab and then press your chosen override key - 5

Make sure edit mode is selected in mode and toggle is ticked)


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .