2
$\begingroup$

So Im working on a loop simulation of inside the body (in this case the bloodstream) and having trouble rendering it. Ive made a circle into a tube (like a very thin wide donut) then into a mesh and added a displacement modifier. I also put a sub surface modifier either side. Nothing too extreme on the settings. Based on (but modified) this tutorial by BlenderMeds. I had the same issue when following the tutorial without my modifications to make it a Loop. https://www.youtube.com/watch?v=98wp3mfjquM

It looks fine in the viewport (not torn/broken) but I cant render. When I try to, there are big gaps with nothing, just grey. Then with the displacement modifier switched off it renders ok (but just obviously without the effect i want).

Sorry if this is a noob question. Ive tried and tried and searched around and cant find an answer!

Render without the displacement modifier Render without the displacement modifier Render with displacement mod turned on Render with displacement turned on Render with displacement settings I want (doesn't show at all) Render with displacement settings I want (doesn't show at all) Tutorial blood vessel not rendering Tutorial blood vessel with displacement, not rendering

$\endgroup$
  • $\begingroup$ could you please post screenshots of what's happening? And also a screenshot of the modifier stack? $\endgroup$ – aliasguru Aug 16 '19 at 8:05
  • $\begingroup$ Or even post your .blend file so we can dig in. $\endgroup$ – L0Lock Aug 16 '19 at 8:55
  • $\begingroup$ Thanks for your replies, Ive put screengrabs and a link to the file in the post! $\endgroup$ – Jess Aug 16 '19 at 11:51
2
$\begingroup$

I'll bet you have a duplicate of the loop from before the displacement modifier was applied rendering at the same time. Disabling the eye icon in the Collections panel doesn't stop rendering. Click on that funnel-looking-thing to enable more filtering options. You want the one for rendering, which looks like a camera. Disable that for the duplicate. You can also do that in the "Object" panel (orange square-shaped tab)

EDIT: Yep. Turn off that camera icon:

enter image description here

$\endgroup$
  • $\begingroup$ Much appreciated! $\endgroup$ – Jess Aug 16 '19 at 12:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.