2
$\begingroup$

I've tried selecting an Armature in Pose Mode, switched to Object Mode, and then Weight Paint mode, but it still doesn't allow me to select bones, among a plethora of other solutions. I'm not sure why, but for some reason it just doesn't work for me. Can anyone help me figure out what I'm doing wrong?

$\endgroup$

6 Answers 6

6
$\begingroup$

top menu Edit > Lock Object Modes > uncheck

Then you can select multiple items when in edit mode. Set your mesh to weight paint while your rig is in pose mode.

$\endgroup$
2
  • $\begingroup$ Jeez, it's always a random checkbox somewhere. $\endgroup$ Jan 30, 2021 at 13:04
  • $\begingroup$ you also need to check that the paint mask & vertex selection boxes are not highlighted next to the Weight Paint selection in the upper left (as momchilo points out below). $\endgroup$
    – jbolt
    Mar 22, 2022 at 2:13
9
$\begingroup$

You need to parent the mesh to the armature first to setup the weights, this is done with Lock Object Modes checked.

In Object Mode, select the mesh, Shift select armature, then Ctrl + P to parent and choose Armature Deform then select any sub-option, like With Automatic Weights.

You should now be able to Ctrl + left mouse on the bones in weight paint mode but only if you have selected the armature first, then Shift selected the mesh, and entered Weight Paint mode.

$\endgroup$
4
$\begingroup$

Select armature - go in pose mod - shift + select mesh - go in weight paint - select bone with ctrl + left click.

Edit: video with your file

$\endgroup$
3
  • 2
    $\begingroup$ It still won't let me select a specific bone with ctrl+left click. When I try to, it just bring me out of weight paint mode into pose mode. $\endgroup$ Aug 15, 2019 at 22:22
  • $\begingroup$ left click by default no? $\endgroup$
    – moonboots
    Aug 16, 2019 at 6:48
  • $\begingroup$ Same problem for me as with LuckyCOINNNN. $\endgroup$ May 27, 2022 at 5:58
4
$\begingroup$

Make sure neither Paint Mask or Vertex Selection (in the upper left corner) is highlighted (so they both got to be off) and you will be able to select individual bones with Ctrl + Left click.

$\endgroup$
2
$\begingroup$

One possible reason of this issue found in Edit > Preferences > Keymap. Go to Keymap and select Key-Binding mode of search. Then type "ctrl left mouse" in the search input field. Look for the result weight paint section, here are 3 values by default. Delete the Weight Paint - ctrl left mouse line with the little x button. Save preferences, and now Ctrl+LMB should work to bone select.

$\endgroup$
2
$\begingroup$

In my blender 4.0.1 version. I use Ctrl + Shift + Left Mouse Click for select bone in weight paint mode.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .