0
$\begingroup$

I did not find this problem / question so far. I've got one mesh with multiple materials on it (Blender 2.8). One of them is a Chrome PBR material with a normal map. I set the material up as shown in the screenshot. The material and the reflections look right in the look dev mode. But when I switch to rendered view I get this squared reflections on my surface depending on the resolution of my mesh (subsurf modifier shrinks the squares but they will not disappear). Smooth shading did not help, all normals are in the right direction and the mesh is free of doubles. The problem has to do with the normal map. When I disconnect the normal map node the material's reflection is shown properly. But I don't know how to fix the problem with using the normal map. (Material: https://www.poliigon.com/texture/metal-chrome-001) enter image description hereenter image description here

$\endgroup$
  • $\begingroup$ What are you UV's like? $\endgroup$ – Joseph Brandenburg Aug 16 '19 at 2:01
  • $\begingroup$ please check if in the outliner a duplicate of your object is present. It looks like the Viewport visibility for that object is turned off, but the render visibility is turned on. Could also be the collection that such object is a child of. $\endgroup$ – aliasguru Aug 16 '19 at 7:39
1
$\begingroup$

Set you colorspace for the normalmap to non-color.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.