0
$\begingroup$

after baking the image texture, the result look's a bit odd/ bad. On the left side you can see the model with the baked image texture, on the right side (the selected model) with the "real" materials. Even when I zoom in, you can see strange transitions (last image).

enter image description here

How do I make the baked texture look like the materials from the real model and how do I solve the artifact problem?

enter image description here

Render: Cycles Render Blender Version: 2.8

Thanks in advance.

$\endgroup$
2
$\begingroup$

The jagged lines in the bake could be caused by a few different things:

  1. Texture Filtering
  2. Bad UV Map
  3. Small Texture Size

1) Cycles image textures have an option in the node for Linear, Closest, or Cubic filtering (Smart is an option if you're using OSL). Try setting this to Cubic. 2)Even if you have a large image, it may be that the UV map in this region is too small to make effective use of the image space. Try altering your UV map to fill more of the image area, if you can. 3) You might just have a really small texture size, so the lines are jagged at that point. I can see the pixels, so this is probably it. Try baking at a higher resolution

Finally, you might use KRITA or GIMP to add a Gaussian blur to the image. You could also use Blender's compositor to do this.

$\endgroup$
  • $\begingroup$ Thanks for the quick answer, your suggestion worked. $\endgroup$ – YN C Aug 18 at 19:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.