0
$\begingroup$

I set up a simple hair dynamics system in Blender 2.8 to replicate the problem I have in my original model. No matter what settings I use the top part of the hair is always stuck in place and stretches to the mesh. enter image description here

Here is a link to the file:

hair dynamics test blender 2.8

There must be something fundamentally wrong either in my setup or in Blender.

Any ideas?

$\endgroup$

3 Answers 3

1
$\begingroup$

Try turning off smooth shading. Select object, Rt click and set to Shade flat. If this works (it worked for me) you have to copy the scalp parent it to the object and turn off show emitter in the particle settings.

$\endgroup$
0
$\begingroup$

A previous Bake seems to be causing the issue.

In Cache, click "Free All Bakes", then relaunch the simulation with the "Play Animation" button.

$\endgroup$
2
  • $\begingroup$ Did you actually download the file and try it? I did a "Delete All Bakes" in the Cache section of the particle tab and it didn't work either. $\endgroup$
    – iblok
    Aug 14, 2019 at 11:04
  • $\begingroup$ Yes I did and it worked yesterday, but today it doesn't. Maybe I did something else and don't remember. You can change a setting (ie, set particle number to 999 instead of 1000) to force the simulation to be recomputed, it works. $\endgroup$
    – thibsert
    Aug 15, 2019 at 10:09
0
$\begingroup$

It seems like manually dragging the frame marker along the timeline before baking fixes the issue. It forces it to load the correct data to bake, I guess.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .