0
$\begingroup$

I've been messing with shaders and render options all day and trying to figure out how to get the objects within my "orb" object to display correctly in my render, but for some reason the viewport looks so much better than the renders and I'm not getting the same effect. Can anyone help me troubleshoot this? I'm kind of new to blender 2.8 and trying to get back into 3d modeling. Thanks for any advice or tips you may have.

$\endgroup$
2
$\begingroup$

The viewport is in 'lookdev' mode. That means there is a hdri image as environment lighting. You don't have it while rendering. Lookdev is a builtin environment lighting for test purpose. Should set up an equivalent environment texture to render it. You can find some available hdri images in your installation directory in 'C:\Program Files\Blender Foundation\Blender\2.80\datafiles\studiolights\world'.

To setup that, you basically need to use this setting where 'forest.exr' is found in the directory indicated above:

enter image description here

But if you just render it, you'll see it in the rendering:

enter image description here

So you need to enhance the world node tree a bit (I've found no option to hide it automatically in Eevee).

enter image description here

This setting says: when a light ray is directly to the camera, then use the second 'background' node which is set with a transparent color.

So you can render this:

enter image description here

Here is the blend file (you may need to reopen/reload the hdri image to make it work in your environment):

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.