2
$\begingroup$

I have file of a mesh and it appears normally in Blender, on my Windows machine, as shown below correct output

But when I open the same file using Blender, on my Ubuntu machine it appears like below

wrong output

So, could anyone explain why is it displaying weirdly on Ubuntu (lower one), meanwhile, on Windows (upper one) it's ok?

$\endgroup$
  • $\begingroup$ Is it the same Blender version? Are you in shaded mode (Z)? $\endgroup$ – Pisurquatre Aug 8 '14 at 9:30
  • $\begingroup$ @Pisurquatre Yes, same verion but one windows and the other ubuntu. I don't know if I'm in shaded mode or not, how to check that? $\endgroup$ – Tak Aug 8 '14 at 12:02
2
$\begingroup$

In Windows you're in weight-paint mode and in Ubunto you're in wireframe view (in object mode). If you want to change the Ubuntu version, hover over the 3D view and hit Ctrl+Tab to switch modes. Alternatively, use the menus at the bottom of the 3D view to switch between modes (see screenshot).

wireframe vs weight paint

| improve this answer | |
$\endgroup$
  • $\begingroup$ I've done this but whenever I choose the object mode and solid it keeps the same, but strangely I find the armature the one changing not the mesh. Not sure why this is happening may be an issue with the blender version on my Ubuntu machine? $\endgroup$ – Tak Aug 9 '14 at 2:04
  • $\begingroup$ When you're in Object Mode and Solid view the body remains a wireframe? Try moving the body mesh to a different layer so that you can work with it by itself. $\endgroup$ – splic Aug 9 '14 at 14:47
0
$\begingroup$

In Blender when you save a file, the user interface for that file gets saved as well. You can choose to use the file's user interface when you open it on a different system.

File->Open (or CTRL O) enter image description here

When the next window opens to select the file press T to enable the tool shelf and look for the Load UI option on the bottom left side of the screen. enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ tried this but still loaded like that can't switch to solid mode $\endgroup$ – Tak Aug 9 '14 at 2:05
0
$\begingroup$

It was a bug in the blender version used. Upgrading the version to the latest one solved it.

| improve this answer | |
$\endgroup$
  • 1
    $\begingroup$ please post information on the version used so others can be aware of the issue. $\endgroup$ – user1853 Aug 10 '14 at 16:44
  • $\begingroup$ I have had a similar problem. It's most likely due to whatever plugins you are using for rigging (rigify?) $\endgroup$ – beiller Mar 16 '15 at 19:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.