0
$\begingroup$

I added hair particles to an object and set the view to rendered in the viewport. With Cycles the hair is rendered correctly, but with Eevee only black lines are displayed. The rest of the scene is rendered correctly with both engines.

$\endgroup$
  • 2
    $\begingroup$ Are you using the Principled Hair BSDF? $\endgroup$ – Millard Aug 10 at 21:04
  • $\begingroup$ No, I'm using particles. There is no shader being used to generate the hair (at least none that is shown in the node editor). $\endgroup$ – LukasFun Sep 9 at 15:17
  • $\begingroup$ I meant the shader you're using for the hair's material. $\endgroup$ – Millard Sep 10 at 22:34
  • $\begingroup$ There is no material for the hair. $\endgroup$ – LukasFun Sep 11 at 14:12
  • $\begingroup$ ok, I was just making sure you weren't using the new hair shader because it only works in cycles and would thus make your hair particles black, but I see you found the answer earlier. :) $\endgroup$ – Millard Sep 11 at 15:10
0
$\begingroup$

The problem with the black lines was caused by an old graphics driver. But the hair was still just displayed as colored lines after that. This however was due to the render setting "Hair Shape Type" which was set to "Strand". Setting it to "Strip" as shown in the image below fixes that.

Hair Shape Type render setting

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.