1
$\begingroup$

I have a wired 3DConnexion SpaceMouse which worked very well with v2.7. However, it has lost its built-in functionality in Blender v2.8.

In 2.7, Blender worked well with the device with smooth pan, zoom, and rotation.

The 2.8 manual makes mention specifically of support for 3DConnexion devices: NDOF Configuration. However, the functionality apparently isn't turned on by default.

I have tried resetting my preferences to factory settings and I've tried adjusting the keymaps in User Preferences, but I'm not entirely familiar with doing that.

Has anyone found the right settings to restore SpaceMouse functionality in Blender 2.8?

Tech details: MacOS 10.14.6, MacBook Pro (15", 2018) and iMac (27", 2019) 3DConnexion SpaceMouse and SpaceMouse Enterprise

$\endgroup$
0
$\begingroup$

I have a 3dconnexion space mouse wireless and in my personal experience, all the basic functions do work without changing the factory settings. However blender still lacks "the what" is built in Fusion 360. In Fusion 360 the space mouse's focus is automatically "locked" to the object you are working on, so you can effortlessly fly around it like an angel. I haven't found the option how to do that in blender with the mouse which makes it more difficult to control.

HP Zbook G3 17" with Windows 10 PRO, 3dconnexion space mouse wireless and latest drivers.

Kody

$\endgroup$
0
$\begingroup$

I found the solution. In preferences, it's the "Deadszone" setting. By default, it's set to ignore movements unless the pressure is high enough which IMO, is too high. I dropped it down to almost 0 and now it's AWESOME!!!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.