2
$\begingroup$

When I tried to load a video to video sequencer, the file name in Chinese could not be displayed.

$\endgroup$
4
  • $\begingroup$ This is a bug, you should report it, so that it will be fixed soon. See blender.org/support $\endgroup$
    – m.ardito
    Aug 10, 2019 at 6:03
  • $\begingroup$ @m.ardito no this is not a bug. $\endgroup$
    – Robert Gützkow
    Aug 10, 2019 at 8:32
  • $\begingroup$ @joseph, it was a video file, with both name and extension in chinese characters? And did you see other strange characters (like boxes) instead of the expected ones or you didn't see the file item at all? $\endgroup$
    – m.ardito
    Aug 10, 2019 at 10:25
  • $\begingroup$ it was "fname.mp4", fname is in Chinese and it was shown as boxes. $\endgroup$
    – joseph
    Aug 10, 2019 at 18:46

2 Answers 2

2
$\begingroup$

The default font used for the interface does not contain all characters, Chinese is one of them.

There are two options to solve this in the preferences (Edit > Preferences)

  1. Activate Translation and set language to Simplified Chinese or Traditional Chinese. It may also work with Automatic depending on your OS language configurations.
  2. Choose a different Interface Font for the interface which includes Chinese characters.

I think the first option is likely the best for your problem. Optionally you can also activate the checkmark next to Interface in the translation options to switch the entire interface to Chinese.

Preferences

$\endgroup$
2
  • $\begingroup$ I activated the checkmark next to Interface in the translation options and I was able to see the Chinese characters. Thanks. $\endgroup$
    – joseph
    Aug 10, 2019 at 19:01
  • $\begingroup$ @joseph If this answer solved your problem, consider marking it as accepted, by ticking the checkmark on the top left of the question. $\endgroup$
    – Leander
    Aug 10, 2019 at 19:07
0
$\begingroup$

As also suggested in another answer, the issue could be solved just by turning on the interface "translation" feature. On my linux mint I created a txt file with some random chinese characters, and it was displayed good on my desktop and in text editor.

But when I tried to load it in Blender 2.80, all I could see was a bunch of boxes instead of the chinese characters.

enter image description here

it was sufficient to enable "translation", keeping it "Automatic" and the UI immediately shown the chinese characters, with no other option enabled, and no other font loaded. I guess why this is not a default option.

enter image description here

@joseph, you could even save your preferences as default after setting this - although on my fresh 2.80 I discovered to have "auto save preferences" enabled...

enter image description here

$\endgroup$
1
  • $\begingroup$ Yes, the issue was solved just by turning on the interface "translation" feature. And "auto save preferences" is enabled in 2.8. Thanks. $\endgroup$
    – joseph
    Aug 10, 2019 at 19:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .