2
$\begingroup$

My problem is pretty straightforward. To weight paint my character I must 1) Select the armature and put it in pose mode 2) Select mesh and put it in weight painting mode For some reason after I put my armature in pose mode I can no longer select the mesh. I attempted to put my mesh in weight paint mode first, but then I could not select the bones. I used automatic weighting to see if the armature would deform, and it does so there is no problem there. Just the auto weights are horrible for this character.

I am using version 2.8 https://drive.google.com/open?id=1RnFKtQMpJs4CX91MXeYArBxmO-Zcu5zg And there is the shareable link. You will see I have a character and an armature.

$\endgroup$

10 Answers 10

2
$\begingroup$

Make sure you untick "Lock object modes" in the Edit tab at the top panel. Trouble is, it doesn't always help. For some reason currently I have the same problem with the OP, Lock object modes is off, but I still can't select my character when in pose mode.

| improve this answer | |
$\endgroup$
1
$\begingroup$

Definitely something strange going on in your scene. I was also unable to select the mesh after starting pose mode. I was unable to figure out what was causing it. Create a new scene and append all of your stuff into it (File -> Append). That worked for me. Make sure to append stuff as Objects, not meshes.

I'm not that familiar with Append, but I believe you can create a new scene, press File -> Append, browse to and select your original file, select the "Object" group, press 'A' (to select all), then press "Append from Library". I believe that will get you back where you were.

| improve this answer | |
$\endgroup$
  • $\begingroup$ I ended up moving everything to a new file. I just created a new file and transferred (appended) everything to it. I believe it might have been because I started the project in an older version of blender. This fixed some initial problems but it cid not let me weight paint in this new file. Very strange $\endgroup$ – Alex Sandoval Dec 19 '19 at 14:56
1
$\begingroup$

Weight paint for rigging in 2.8 doesn't work like in 2.79. To weight paint in 2.8:

  • Select your armature in Object mode.
  • Shift select your character object.
  • CtrlTab to switch your character object to Weight Paint mode (or header menu > choose Weight Paint mode). The armature has automatically switched to Pose mode.
  • Choose the bone you want and paint.
| improve this answer | |
$\endgroup$
  • $\begingroup$ It won't let me weight paint, even with those steps $\endgroup$ – Alex Sandoval Dec 19 '19 at 14:57
1
$\begingroup$

I had this problem and parenting the bones/armature to the mesh helped. This is in case you forget to do it just as I did.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Explain what you mean. Are you saying that I did not parent the mesh to the armature? I did do that $\endgroup$ – Alex Sandoval Dec 19 '19 at 14:53
1
$\begingroup$

Ok, I had the same problem and was able to fix it, but you have to remake armatures.

  1. Export your model as a .OBJ
  2. Make a new default file go to
  3. After that, click File > Defaults > Load Factory Settings.
  4. Import .OBJ
| improve this answer | |
$\endgroup$
1
$\begingroup$

What worked for me was to select the mesh in the collections panel on the left (At least that is possible in pose mode), and select the bone on scene holding my shift key. This only works as long as you are parenting the mesh to the bone. Done the other way round it doesn't work.

| improve this answer | |
$\endgroup$
0
$\begingroup$

You have to select the bone in pose mode, go out of pose mode and then select your mesh. Blender remembers which bone you selected. it is a little tedious, but at least it works.

Hope this helps!

| improve this answer | |
$\endgroup$
  • $\begingroup$ Tried that before. Didn't work on my end $\endgroup$ – Alex Sandoval Aug 10 '19 at 0:08
  • $\begingroup$ you must be one of those rare cases. maybe you should report the bug to the blender developers. maybe one of them can help you. $\endgroup$ – Millard Aug 10 '19 at 0:51
  • $\begingroup$ wait, just making sure, are you forgetting to add empty weights for the armature? $\endgroup$ – Millard Aug 10 '19 at 0:55
0
$\begingroup$

I was able to fix this for my project by deleting the Layout workspace and recreating it, as per https://developer.blender.org/T59294

After that, I could select the mesh from pose mode, as long as "Lock Object Modes" is unchecked.

| improve this answer | |
$\endgroup$
0
$\begingroup$

Pressing Toggle X-Ray (Alt + Z ) helped me.

| improve this answer | |
$\endgroup$
0
$\begingroup$

First select armature and mesh in object mode with shift key. Then go to Weight Paint Mode. In blender 2.8 and above use Ctrl + Left Mouse click to select a bone. Now , you can clearly see which vertices are connected to which bone.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.