3
$\begingroup$

Can anyone tell me what's wrong in this picture? This is my first attempt at baking a normal map from a high-poly mesh to a low-poly mesh, and I've been stuck at this step for hours. I've followed tutorials step-by-step, and still can't figure out what's going on. All the related posts I've looked at are about some specific artifact appearing in an otherwise decent normal map; I've tried changing the ray distance and thought about trying to make a cage, but as you can see in the picture the failure is so complete that I'm sure I'm missing something really fundamental here... enter image description here

$\endgroup$
1
$\begingroup$

Solved! For the sake of better organization, I had my high-poly meshes in a separate collection from my low-poly meshes.

enter image description here

In the Outliner window, I dragged the high-poly mesh into the same collection as the low-poly mesh, and after that the normal map baked properly (not perfectly, but it's at least a starting point.)

So I think what I'm missing is an understanding of what Collections are in Blender and how they are used; I was assuming they were a way to organize and collectively edit groups of objects in a scene (basically what it says on the tin), but evidently there's more to it than that.

(Haven't looked into details of why this worked yet, but it just bugs me when an op comes back with "solved!" but gives no explanation of how they solved it, so this is what I've got.)

$\endgroup$
  • $\begingroup$ that is what collections are for. I'm not sure if this is a bug, or just something you have to do. $\endgroup$ – Millard Aug 10 at 17:22
0
$\begingroup$

I have only one collection and only one mesh and I am getting the rainbow normal as well - I don't think the collections have anything to do with this solution.

$\endgroup$
  • $\begingroup$ Rainbow looking normal maps are expected for object-space normals, so do be sure to check it's not that. The original poster had a screenshot of his normal settings so we can confirm it's set to tangent space - that said, last I checked tangent space was still the default. $\endgroup$ – Ben Sep 6 at 20:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.