0
$\begingroup$

Each time I hit 'I' to insert a keyframe in the Action Editor, if the previous keyframe on that channel is linked, the new one will be linked too (with a thick horizontal line). I can't find a way on the menu to disable or get rid of that #$%@^ link which affects the next and previous keyframes in an undesirable way. I'm sure there must be a way (although very well hidden). So what is the magic spell for this purpose?

enter image description here

If I change the position on the upper channel shown at the current frame, all previous (linked) frames on that channel take that new position -I don't want that. In the lower channel though, if I change the value no horizontal line appears.

UPDATE: I uploaded this Blender screencast for proof of this unjustified behavior - and for a clearer explanation.

https://www.youtube.com/watch?v=pCs95EJDkZ8&feature=youtu.be

$\endgroup$
6
$\begingroup$

The yellow lines do not represent "links" but selected keyframes with the same value.

Form the Blender Manual

One of the key feature of this window is that it allows you to visualize immediately which channel (i.e. Ipo curve) is really affected. When the value of a given channel does not change at all between two neighboring keyframes, a gray (unselected) or yellow (selected) line is drawn between them."

If what's bothering you is the way the interpolation works between keyframes , you should edit those not the dope sheet but on the Graph editor window.

In this example you can see the same key frames for the location of the X channel represented on the dope sheet and the graph editor, Notice how the Yellow lines between keyframes coincide with the flat regions of the graph, and how the line disappears where there is some transformation on the value in the graph.

enter image description here

EDIT A note on the Hierarchical system and the Dope Sheet

Everytime you add keyframes using the I key you are presented with an option to choose what channels you want to use for the keyframe, for example Loc,Rot_Scale or Loc_Scale, Rotation only, all channels, only selected channels. The channels you choose are what is called a Keying Set.

The idea behind keying sets is to keep things organized, for example if you don't want to have a location keyframe when you just need to rotate.

In the DopeSheet you have access both to the keying sets and individual channels and they are organized in a hierarchical structure. You can move, delete or add keyframes with ease.

Here's an example: At the top of the Hierarchy you'll find the dopesheet summary that encompasses every keyframe on the scene. On the second level there are the individual objects with their own keyframes. enter image description here Click on the trianlges on the left to reveal the next levels down. enter image description here

The lines rows in green are the Keying Sets

enter image description here

And further down are the individual channels.

enter image description here

Depending on where in the hierarchy you move (or add, or delete) the keyframes, you might affect everything, just the keying set or individual channels.

As for the Yelllow line... Sorry Still no magic nothing there... It doesn't hold anything inside it: It doesn't have any other purpose than to show information in unchanging values between keyframes.

$\endgroup$
  • $\begingroup$ Thanks, but I know that. See the screencast of the issue I added. $\endgroup$ – user5515 Aug 7 '14 at 21:38
  • $\begingroup$ BTW, I understand this is not the proper terminology, but in a way all the dots that are connected with those lines are linked because if you change one, all change. $\endgroup$ – user5515 Aug 7 '14 at 21:46
  • $\begingroup$ There is indeed a hierarchy to the arrangement of the rows of keyframes. Top level, mid level and low level. If you move the keyframes on the top levei it will affect all the keyframes in lower levels, To move individual keyframes you have to do it on the lower (individual) channels Please read wiki.blender.org/index.php/Doc:2.6/Manual/Animation/Editors/… $\endgroup$ – cegaton Aug 7 '14 at 22:33
  • $\begingroup$ In case you don't know, keyframes can be selected and deselected like everything else in blender. A will select/deselet all keyframes, Right clik will select individual keyframes, G is the tool to grab (move) keyframes, etc $\endgroup$ – cegaton Aug 7 '14 at 22:38
  • $\begingroup$ How about the update I added? $\endgroup$ – user5515 Aug 7 '14 at 23:11
2
$\begingroup$

Bit hard to tell what you mean without a picture. And I'm also not sure what you mean by 'linked keyframe'.

However, a line between two keyframes is just to show that the two keyframes are the same value and so anywhere between those keyframes is also one continuous value.

As far as I know there is no way to turn this off.

$\endgroup$
  • $\begingroup$ I've added a picture and description. $\endgroup$ – user5515 Aug 7 '14 at 18:42
0
$\begingroup$

Ok, the solution is ridiculously simple:

At the first frame, a keyframe should be inserted for each required channel by using 'I' in 3D view and selecting them from the popup menu ('Insert keyframes" from the timeline cannot be used without this initial process). Then those channels are enabled for the whole length of animation without any of the issues mentioned.

It turns out that in this case, location wasn't inserted in the first frame (for the blue object), hence this behavior.

Thanks for all help!

$\endgroup$
  • $\begingroup$ In my case values were already inserted, yet I went ahead and re-inserted my key frames everything stopped acting funny (which the problem started with the last key frame). $\endgroup$ – CrandellWS Apr 21 '18 at 19:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.