0
$\begingroup$

I open Blender 2.80 (official release, not a beta or RC) and get the new scene with the usual 3 objects present (camera, light and cube). I select the cube, press 't' for the tools menu and click on the Move tool. The usual 3 axis glyph appears at the cube's origin as expected. But if I use the hotkey 'g' to activate the move transform instead of selecting the tool from the menu with the mouse this glyph does not appear. The exact same problem exists if I use the a hotkey for rotate or scale as well. Why? Is there some clickable checkbox setting hidden somewhere that could have disabled this?

$\endgroup$
0
$\begingroup$

That is by design. When you are using shortcuts you can restrict the movement to a single axis by pressing G followed by X, Y or Z. Alternatively to restrict the motion to only two you can use SHIFT + the axis you don't want any movement on. Therefore there is no need for the gizmo in that context.

If you want to enable the move version with the gizmo press SHIFT+SPACEBAR+G or you can right click on the icon in the toolbar and assign your own shortcut. Just make sure it doesn't conflict with any existing shortcuts.

The gizmos for translate, rotate and scale can be permanently enabled in the Viewport Gizmos.

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.