0
$\begingroup$

I'm trying to delete some bones that are included by default when you rig a model with rigify. The bones themslves are not used for anything and I'd like to delete them as they are causing problems when I try to export the animated model to fbx. Any help is appreciated, thank you! Facial bones

Attached Blend file

$\endgroup$
  • $\begingroup$ Not sure what the issue is here, but the way I tend to export animation is duplicate and separate the deform bones, then constrain them to copy transforms from the original deform bones, and finally bake the animation to keyframes. This is somewhat tedious if you don't use Python to automate the process. Note that for gltf export (and maybe fbx,not sure), you have to delete the original armature before exporting since the exporter currently can't process multiple rigs at a time. $\endgroup$ – Joseph Brandenburg Aug 8 at 19:57
1
$\begingroup$

Okay, so the issue is with your deform bones, particularly the facial deform bones. If you wanted to use them, you could re-align them, but since you do not, it is easier to just go ahead and delete them and then re-parent the armature. Here's how:

STEP 1

Select your armature and then under the Armature Properties panel, switch to Rest Position. Secondly, switch your active Armature Layer to be only the 3rd from the bottom most left. (See picture below, circled in red).

enter image description here

STEP 2

With the armature selected and only the deform layer active, tab into edit mode. Now you can delete all the bones you do not need. For this example, I selected the three head bones you probably will want (see selected bones in the photo below). Then I hid them (hotkey H) so that I would not accidentally delete those ones that I need. After they were hidden, I selected all the face deform bones and deleted them.

enter image description here NOTE: The selected bones in this photo are the ones you should NOT delete. You can delete the rest of the face bones for your purpose (the ones around the eyes, ears, and jaw)

STEP 3

After having deleted the bones you do not want. Go back to object mode and select your mesh. Then go to the Object Data property tab and under Vertex Groups, click the arrow button and select "Delete All Groups". Don't worry, one more step and we're almost done!

enter image description here

STEP 4

Now, with your mesh selected in object mode, select your armature so that it is the active object (orange outline instead of yellow). Then parent (control + P) the mesh to the armature using Automatic Weights. Go back to Pose Position and check out your animation. It might need some tweaking, but you will not have any facial issues when exporting down the road.

EDIT: I deleted some posts because I did not realize the format was to keep editing my first answer. I apologize, but wanted to post a comment that got deleted in the clean-up about the OP's FPX export settings. @Alberto Elorduy: By the way, my main fbx export settings are Selected only, Armature, Mesh, and empty. In armature only export deform bones, don't apply modifiers, and smoothing to faces. In animation I choose baked animation, key all bones and force start/end.

enter image description here

$\endgroup$
  • $\begingroup$ Thank you for your help Joe! I haven't been able to solve it as there's still deformation when exported to fbx. There are still some particular issues. For example the spine seems duplicated for some reason. Anyways, do you think I can pay you some to help me solve this? Or has the model actually worked for you? $\endgroup$ – Alberto Elorduy Aug 9 at 8:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.