-1
$\begingroup$

I've been doing a lot of modelling for computer parts and one thing that I'm struggling with is making the FANS SPIN and have blur to it like in real life.

Please look at my video animation on the FANS. https://youtu.be/COu1q46biiI

I've tried adding VECTOR BLUR in COMPOSITING but it also blurs the CAMERA MVOEMENT and ruins the animation. I just want the blur to take effect on the fans themselves.

$\endgroup$
  • 4
    $\begingroup$ Have you tried Motion Blur option in the Render panel? I don't know a lot about it but it seems like it's made for this... $\endgroup$ – moonboots Aug 8 '19 at 14:32
  • $\begingroup$ Also, if you put your fan in one particular layer and the rest in another one, I don't know how it could affect anything else than the fan... but again, check Motion Blur, as I guess it is supposed to be directional and respect the fan movement $\endgroup$ – moonboots Aug 8 '19 at 14:36
1
$\begingroup$

Providing they are moving fast, you should be able to achieve it ticking motion blur in the render panel:

Motion blur

You can also adjust different factors inside the tab. If you find that you don't want motion blur in the other moving parts you can play with these settings or animate the values.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Hi guys, tried all your suggestions but nothing really worked. $\endgroup$ – Zamboolah Aug 10 '19 at 11:14
1
$\begingroup$

I would agree that you would need to render in cycles, and composite the two together, due to the renderer also reading the vectors of all objects in the camera. If you are rendering out EXRs, try adding a layer that is just the vector pass for the blades, then apply the vector blur using just that layer of the EXR (IE: In Nuke either select the "Blade Vector" layer in the the Vector panel, or Shuffle the layer into the appropriate layer for the Vector Blur to work.)

Vector Blur Workflow In Nuke

Shuffle In Vector Blur Layer On Nuke

| improve this answer | |
$\endgroup$
-2
$\begingroup$

You can use motion blur, but unfortunately you can only limit it to certain objects if your using cycles. NOOOOOOO! in order to disable it, just go to the object panel in the properties panel. under Motion Blur, uncheck it. hopefully soon this will be available in eevee. Hope this helps!

| improve this answer | |
$\endgroup$
  • $\begingroup$ actually I was wrong :) You can only have motion blur for the camera movement. Even more NOOOOOO! $\endgroup$ – Millard Sep 14 '19 at 0:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.