0
$\begingroup$

I have some free downloaded OBJ 3D objects like this cat (http://www.cadnav.com/plus/download.php?open=0&aid=48009&cid=3). It have its material MTL file to give the cat a real appearance. (http://img.cadnav.com/allimg/190709/cadnav-1ZF9121629.jpeg) I have both files in same folder, of course. However, after I import the OBJ and press Alt + Z, it seems Blender ignores the texture. It happens with other OBJ/MLT imported.

Please, could you help me? What am I doing wrong?

$\endgroup$
0
$\begingroup$

The problem is that the .mtl file is not assigning the texture. There is no map_Kd attribute saved.

newmtl Material__27
illum 4
Kd 0.50 0.50 0.50
Ka 0.00 0.00 0.00
Tf 1.00 1.00 1.00
Ni 1.00
Ks 0.50 0.50 0.50
Ns 18.00

If you append map_Kd cat.png as a new line, it will load the mesh with a texture. However the UV layout seems to be made with a mirror modifier applied which causes the texture to look very glitchy. This could be solved if you're willing to fix it.

$\endgroup$
  • $\begingroup$ I did what you suggested and it worked like a charm. I can't understand why Cadnav web doesn't test previously 3D models before put them to download. It's a pity. $\endgroup$ – Rafael Linux User Aug 9 at 7:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.