1
$\begingroup$

I have an Addon I'd like to use in Blender 2.8. But when I would try and import the addon from my files, it wouldn't appear in the addon list so I could enable it. I've tried removing all dots (.) from the source file(s), and I tried manually putting the .py files in blenders file location for it's scripts-addons. Is there something I'm missing? Please help! The "modules installed" message posted below. enter image description here

$\endgroup$
  • $\begingroup$ Are there any errors displayed on the console when you install your add-on? Why would you remove all dots from the file? That will break the script because Python uses the dot in it's syntax for accessing properties and functions of an object. $\endgroup$ – Robert Gützkow Aug 8 '19 at 7:35
  • $\begingroup$ Sorry, I think I said that wrong. I didn't remove the dots from the python script, but the files folders and file names. I edited the main post and added what the message says above^. $\endgroup$ – Praxis Visuals Aug 8 '19 at 18:40
  • $\begingroup$ Recommend for a commercial addon seeking support from where you obtained it. @rjg There may be one top level folder with a dot that requires renaming, from the installer using zipfile name, and the download page naming the zip. $\endgroup$ – batFINGER Aug 8 '19 at 18:53
  • $\begingroup$ @batFINGER ah yes, that makes much more sense. The way I've read it initially was that literally all dots in the source have been removed. $\endgroup$ – Robert Gützkow Aug 8 '19 at 19:08
  • $\begingroup$ I read it that way too. $\endgroup$ – batFINGER Aug 8 '19 at 19:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.