0
$\begingroup$

There is already a post about this (reference: https://cvl-demos.cs.nott.ac.uk/vrn/index.php), but it hasn't been resolved and I'm evidently too much of a noob to even comment on it, but I'm having the same issue and have tried a fix that others have posted as successful. It is not successful for me. When I try to import the OBJ created by the site, I get this...

enter image description here

enter image description here

$\endgroup$
2
$\begingroup$

The problem is that .obj doesn't support vertex color and what this website is doing is against the specification of the format. In Blender 2.8 you will be able to import the model, but the vertex color is ignored.

I would suggest to load the .obj into a software that implements the feature of storing vertex color after the vertex coordinates, for example MeshLab and then export it to a file format that actually supports vertex color, e.g. .ply. You can then import that file into Blender with vertex colors.

$\endgroup$
  • $\begingroup$ So, this works, but, from the standpoint of a noob like myself, it still doesn't seem to work as I would expect. The .ply vertex color can only be seen in Vertex Paint Mode. What can I do to view it in Object Mode, Edit Mode, or with a camera? $\endgroup$ – Jerry Dickerson Aug 8 at 14:00
  • $\begingroup$ If you want the shader to use the vertex color, you need an Attribute Node and type in the name of the vertex color layer, then connect that to the color socket of a shader node, such as the Principle Shader. From an older version of Blender, but the basic principle is still valid: blender.stackexchange.com/questions/19459/… $\endgroup$ – rjg Aug 8 at 14:05
  • $\begingroup$ Still unable to view color data in anything beside Vertex Paint Mode. (See added image in original comment). $\endgroup$ – Jerry Dickerson Aug 8 at 15:23
  • $\begingroup$ Good question. I'll look into it, not sure why this happens. $\endgroup$ – rjg Aug 8 at 16:05
  • $\begingroup$ I open the file again and adjusted the Emission parameter in the Principled BDSF node and the image appeared in Object Mode. Problem solved! Thanks for your help! $\endgroup$ – Jerry Dickerson Aug 8 at 18:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.