2
$\begingroup$

Edit: Ok so it has been fixed by RJG, thanks to him, I had the same shortcut for select vertices and select gizmo, which seems the case by default? and I had to came back to right click for selecting vertices, which is perfectly fine to me.


I meet this very bad problem with 2.8. when the gizmo is displayed.

In Object mode it causes less problems, but when I switch to Edit mode and try to select a vertex close or even not so close to the gizmo, as if it seems like it's the same shortcut, Blender thinks I want to select and move the gizmo instead of the vertex, as if the gizmo was on a layer over the mesh, and not the opposite, which messes up a lot the work with the mesh, it makes you often move inadvertently some vertices.

In 2.7 it didn't work that way, because it was not the same keying for selecting vertex and selecting gizmo.

This doesn't seem logic nor convenient at all to me, it's even very bad :/ Am I missing something like an option to activate?

In advance thanks for your answers...

enter image description here

$\endgroup$
  • $\begingroup$ Same behavior in a more or less current master build. However I don't find this particularly problematic because you can either just switch to select box or zoom in which will shrink the gizmo relative to the object size and the vertex can be selected without problems. $\endgroup$ – Robert Gützkow Aug 7 at 16:59
  • $\begingroup$ switch to select box or zoom in are not really solutions, on the contrary I find it very annoying :(( $\endgroup$ – moonboots Aug 7 at 17:01
  • $\begingroup$ Don't really catch the point? Are you left click select or something? $\endgroup$ – lemon Aug 7 at 17:11
  • 2
    $\begingroup$ @batFINGER !! left click select?? have you all became misbelievers?? ; ) $\endgroup$ – lemon Aug 7 at 17:28
  • 1
    $\begingroup$ I'm currently not at my computer, so I can't test it, but perhaps this is the solution: twitter.com/YegorSmirnov_/status/1159588211963961346?s=19 $\endgroup$ – Robert Gützkow Aug 8 at 22:46
4
$\begingroup$

Credit for the following answer goes to Yegor Smirnov who tweeted about this.

The solution for this problem is to set the Activate Gizmo to Drag in Keymap > Preferences.

The tooltip explains what it does:

Drag allows click events to pass through to the tool, adding a small delay.

enter image description here

$\endgroup$
  • $\begingroup$ thank you been looking for this solution $\endgroup$ – barkest Aug 9 at 10:30
  • $\begingroup$ @barkest You're welcome, but the credit goes to Yegor. I just stumbled upon his tweet by accident. $\endgroup$ – Robert Gützkow Aug 9 at 10:33
  • $\begingroup$ Thanks from me too. While Left Click Select is default (immaterial of whether one likes it or hates it), certainly looks like making DRAG the default too, would remove a conflicting default. In quick tests haven't noticed any undesirable side-effects. $\endgroup$ – batFINGER Aug 9 at 10:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.