2
$\begingroup$

I am following a tutorial and i am setting up the lighting. I want to hide the spotlights inside my lamps and torch so that it seems more realistic. The thing is that no matter how big the radius is, no light is coming out. I've searched online, but i can't find anything related. Here is the problem.

Spotlight radius not working

As you can see, the radius is bigger than the torch but no light is coming out. If i remove the torch, it works perfectly.

I tried changing the light type to point and area and the radius setting works fine, even in cycles. But when i set it back to spotlight, i still have the same issue.

Is there something i don't understand in the radius setting? I'm pretty sure it is not a bug, since the radius worked in the tutorial i saw.

(disclaimer: this is my first post, i don't know if the formatting is right)

Edit: The light in the pic is from an other spotlight with the same issue, I just places it outside the object in order for it to work.

$\endgroup$
5
  • $\begingroup$ I can see light being emitted from the spot in your screenshot, so that seems to be working. If I understand you right the actual problem is that the light doesn't go all the way to the displayed cone? That is because of the Blend parameter which makes the light fade towards the edges of the cone. If you set Blend to zero you will have absolutely sharp light within the cone. If you want to keep it soft but increase the angle, you can do so by increasing the Size. $\endgroup$
    – Robert Gützkow
    Aug 7, 2019 at 16:14
  • $\begingroup$ Sorry, my bad that i didn't specify. The light in the image is from an other spotlight which has the same problem. I just placed it outside the object. I could do the same with the torch, but it would look like the light comes from a single point of the torch instead of all the surface. $\endgroup$
    – ZisElite
    Aug 8, 2019 at 9:12
  • $\begingroup$ Well then the issue is probably that you put the light inside closed geometry. Which is the equivalent of putting a lamp into a closed box IRL, you won't get much light out of it. You could turn the front of the torch into a mesh light by assigning an emission shader to the front faces. $\endgroup$
    – Robert Gützkow
    Aug 8, 2019 at 9:22
  • $\begingroup$ Well, even if it is inside closed geometry, the radius setting is set to bigger than the geometry. It should emit light normally. At least that's how it works in the tutorial i saw and it is made with the official release. $\endgroup$
    – ZisElite
    Aug 8, 2019 at 9:32
  • $\begingroup$ If its large enough, yes, but it will also create undesirable light bleed where it crosses the geometry. I'll write you an answer on how to set this up, will take a moment though. $\endgroup$
    – Robert Gützkow
    Aug 8, 2019 at 10:12

2 Answers 2

2
$\begingroup$

This answer has been update for Blender 2.81. The original one was mistakenly written for Cycles.

There are three parts of the problem that need to be addressed:

  1. In Blender lights don't create any visibile geometry, therefore you don't see the source of the spotlight that is emitting the light.
  2. The spotlight placed inside a closed object wasn't emitting light to the outside of the object.
  3. The light cone is only visible when geometry is hit by it or volumetric effects are introduced.

The first problem can be fixed by assigning a shadeless or emissive material to the front of the torch.

The second issue doesn't exist in Blender 2.81 and later when using Eevee, since lights can pass through the enclosing object. However there is no need to put the light inside the object. You can place it slightly in front of the torch and it will give you the desired visuals as well. For Cycles you will either have to place the spotlight outside of the object as well or assign a transparent material to the front which allows the light to pass through.

Spotlight with fake front, 45° size Spotlight with emissive front, spot light placed outside with a spot size of 45°, contact shadows enabled and an irradiance volume to bake indirect light.

Spotlight with fake front, 80° size Spotlight with emissive front, spot light placed outside with a spot size of 80°, contact shadows enabled and an irradiance volume to bake indirect light.

An alternative solution when using Cycles is a mesh light which could be placed inside the torch. Since mesh lights are actual geometry, they are also visible in the render, thereby solving problem 1). This approach would require to model an approximation of the torches interior. However this isn't as versatile as using a spotlight, since the shape of the light cone would be determined by the geometry of the torch and the mesh light. Therefore, adjusting the look is much more difficult compared to the settings of the spotlight.

In order to solve problem 3) you would either need to ensure that the torch hits objects in the scene to make the light cone visible, e.g. walls, or add atmospheric effects simulating dust in the air. This can be accomplished by adding a cube into the scene that is scaled to encloses the volume that should scatter the light. Assign a Volume Scatter material with a low density to the cube.

Spotlight with volumetrics

$\endgroup$
3
  • $\begingroup$ Thank you for taking the time to prepare this. In my pic, i actually implement your first suggestion. My problem is that no matter how big the radius is, the moment the spotlight passes past the emission surface, all light is blocked. Is there any chance that i have to activate something in the render settings? $\endgroup$
    – ZisElite
    Aug 8, 2019 at 11:23
  • $\begingroup$ @ZisElite Place the spot light outside of the torch! If you put it inside either the spot light size is too small, which results in the spot light not lighting the scene at all or it exceeds the diameter of the mesh, which results in the scene being lit but artefacts occur where geometry and spot light intersect each other. Both of these cases aren't great. $\endgroup$
    – Robert Gützkow
    Aug 8, 2019 at 11:37
  • $\begingroup$ OK, thank you. i'll do that ! $\endgroup$
    – ZisElite
    Aug 8, 2019 at 11:40
1
$\begingroup$

i had the same problem and after reading the comment section found someone with the same problem. and he answered, it's not the radius but clipping that we need to increase. so I tried with the default radius but set the clipping to 0.65 and it worked! the clipping option is inside the shadow section btw

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .