2
$\begingroup$

In Blender 2.8, I have applied a Background image of a sky-scape to the camera view and have hit render. However, the rendered image shows the cube and gray world background, not the cube and the sky background image. I have fiddled about with the settings but to no avail.

Any thoughts?

blender camera image unrenderable

Edit 1

I believe this question to be different than the question, "Why won't my 'background' render" (of which this question was closed as a duplicate) because the image I have is a Background image. The question mentioned by Ketchup boy 2002 relates to an image applied to an empty, which apparently is not renderable.

$\endgroup$
0
4
$\begingroup$

Problem

This behavior is because Object Data > Background Images only shows the image in the viewport -- there is no physical image. An easy workaround uses compositing.

Workaround

First, go to the Render tab > Film dropdown and check Transparent. This will tell Blender to only render the cube as opposed to the cube and the gray background.

Next, switch from the Layout layout to the Compositing layout. Add an Input > Image node and use the bottom left button to select your image (it has already been added to your .blend file, so it should be there).

Add a Distort > Scale node and connect the Image node > Image output to the Scale node > Image input. Set the Scale node > dropdown to Render Size. Add a Color > Alpha Over node and connect the Scale node > Image output to the top Alpha Over node > Image input. Connect the Render Layers node > Image output to the bottom Alpha Over node > Image input. Connect the Alpha Over node > Image output to the Composite node > Image input. Your nodes should now look like this:

enter image description here

Render.

enter image description here

$\endgroup$
2
  • $\begingroup$ Fantastic Shady Puck! Followed your node editor configuration (adding my image) and got the result! Thanks for sharing your knowledge. $\endgroup$
    – Dean
    Aug 7 '19 at 21:03
  • $\begingroup$ @Dean Glad to help! If you liked my answer, please consider accepting it by clicking the check mark to my answer’s top left. I would really appreciate it! $\endgroup$
    – Shady Puck
    Aug 7 '19 at 21:24
0
$\begingroup$

I believe background and reference images do not contribute to the final render. To get an image in the render you have two options.

1) Render from the view port. In the 3D view you can go to View > Render Viewport Image or Render Viewport Animation. This may not be ideal if you have more complicated materials and lighting, so I would recommend the following....

2) Use Import Images as Planes Addon. This comes included in Blender, you just have to enable the add-on in user preferences. Then in the 3D view, you can Shift+A or Add Mesh and in the Images sub-menu, you should now see "Images as Planes". In the File Explorer window where you select the image, there are several options in the lower left hand menu, including align to camera.

Both have the advantages and disadvantages. The first method allows you to see your images in Wireframe or Solid* mode, which is great for reference, while the second method is better if you want to actually use an Image in your final render.

Hope this helps. Let me know if you have any questions.

*Update: I mentioned earlier you can not view an Image Plane in Solid mode, but if you select "Texture" as Color in the Solid Shade drop-down menu (see attached), you can view the Image in Solid Mode.

enter image description here

$\endgroup$
2
  • $\begingroup$ Hi cgi-joe, thanks for your answers to my question but I couldn't find 'render viewport image' in the 'view' menu. Is it there in Blender 2.8? Shady puck gave me the answer I was after, but the 'import images as planes' addon is a good alternative. $\endgroup$
    – Dean
    Aug 7 '19 at 21:17
  • $\begingroup$ Are you in the 3D View? The menu is in the header. Make sure that the header isn't hidden by pressing Ctrl+Alt+Shift+H. Then it should be View > Viewport Render Image or Viewport Render Animation. $\endgroup$
    – cgi-joe
    Aug 7 '19 at 22:26

Not the answer you're looking for? Browse other questions tagged or ask your own question.