4
$\begingroup$

When I render the scene, the shadows of the fish have become distorted and enlarged. I have played around with the shadow settings on the meshes, materials, textures and environment but cannot fix the problem. Any help will be appreciated. Thanks.

scene and settings

$\endgroup$
  • $\begingroup$ What happens when you have a flat ground mesh? I think the issue is that the ground mesh is warped. $\endgroup$ – CharlesL Jun 28 '13 at 13:40
  • $\begingroup$ @CharlesL Have just replaced the floor of the lake with a flat plane and got exactly the same result. $\endgroup$ – Lindsey Jun 28 '13 at 13:50
  • $\begingroup$ are you using a spotlight or a Sunlight? is it that you want to shadows not to be several times bigger than the fish? $\endgroup$ – zeffii Jun 28 '13 at 13:52
  • $\begingroup$ @Zeffii I am using a sunlight. yes that is exactly what I want $\endgroup$ – Lindsey Jun 28 '13 at 13:53
  • $\begingroup$ are the shadows OK when you hide the water? $\endgroup$ – zeffii Jun 28 '13 at 13:56
4
$\begingroup$

It appears from your image that you have two lamps lighting the scene. The properly sized shadows from your sun lamp are visible, but you also apparently have a spot lamp near the surface of the water, and that is causing the enlarged shadows. Look in the Outliner panel to make sure you have this spot lamp disabled.

enter image description here

enter image description here

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.