0
$\begingroup$

I have an Addon I'd like to use, but when I would install the .py file, theres a message on the far right saying I need to "upgrade to 2.8x...". The addon seems to be added into my Addons list, but when I search for it in Blender, it cannot be found. Is there anything I can do to use this addon?

enter image description here

$\endgroup$

closed as too broad by batFINGER, Duarte Farrajota Ramos Aug 7 at 9:35

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    $\begingroup$ AFAIC questions asking to upgrade commercial addons should be off-topic on BSE. See the addon page.r It clearly mentions being upgraded for 2.8. $\endgroup$ – batFINGER Aug 7 at 8:54
2
$\begingroup$

Unless you're comfortable reading and writing Python, you won't be able to do anything but wait for the addon creator to do it.

2.8 changed the API quite a bit, but this addon may or may not use the parts that changed. So updating the addon might be as easy as changing a few lines, or as difficult as a complete rewrite of several parts of the script.

Your best bet is to use it in 2.79 for now and link/append it in.

$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.