2
$\begingroup$

I always work with sky and sun light high values to emulate real light, this leads me to use negative values on the exposure, usual linear workflow for better GI bounces, this causes the glass shader to look black, somehow, is there any setting to correct this or is it a 2.8 bug?

here you can see how only changing the exposure setting and the world intensity cahnges the shader appearance

Glass Shader looks dark with exposure value low

$\endgroup$
  • $\begingroup$ What does a negative exposure setting actually mean?? That doesn’t make sense in the real world (just like negative illumination or negative RGB on a surface. You can’t get an image by opening the shutter for a negative amount of time. You ask if it’s a 2.8 bug - have you tried it at other releases such as 2.79? If so, how did it behave? (Same? Different?). IMO this is a setting outside the scope of how it’s designed to work - so it isn’t defined how that setting should behave - so it’s not unexpected behaviour since we don’t actually know what that is supposed to be doing. $\endgroup$ – Rich Sedman Aug 7 at 22:42
  • $\begingroup$ @RichSedman great question, i did a similar setup in 2.79 and the problem remains the same,<br/> the negative exposure its there because blender doesnt have a physical camera like vray with exposure settings like ISO, shutter and aperture, the negative only illustrates that your are lowering the exposure over the base which is 1, i'm not sure how the math works but the glass shader seems to be the only thing affected by it, hence the reason of my question. <br/> edit: im trying to tag an image of the 2.79 setup, but i cant figure it out yet $\endgroup$ – Ivan Beoulve Aug 8 at 0:15
1
$\begingroup$

I can replicate this - both by changing the Color Management 'Exposure' setting or by changing the Film 'Exposure' setting - although the two seem to be scaled differently, with the -10 -> +10 Color Management setting changing by a factor of 2 for each unit change (so '0' is 1, '1' is 2, '2' is 4, '3' is 8, etc. - with similar for negative values, so '-9' in your example seems to actually relate to a 'Film' exposure of 1/2^9 = 1/512 - so negative values are actually valid in this case.

After varying various other factors, I managed to get around the 'darkening' by disabling the 'Indirect Light' setting in the Light Paths panel (at 2.8 - at 2.79 this was in the Sampling panel). This seems to indicate that the issue is that the Indirect Light is being lost due to being below the Indirect Light clamping setting. Setting Indirect Light clamping to zero (to disable clamping) fixes the issue in my case.

$\endgroup$
  • $\begingroup$ awesome!, I would have never thought of that setting, that setting was defaulted at 10 in my setup somehow, and found that a value of 500 also gets rid of the darkening (not sure what it would do on my final renders haha) I've read that it helps with fireflies, but hurts the strength of reflections, I might have to deal with fireflies some other way... if this setting could be implemented somehow at the shader level that would solve the issue. thank you! $\endgroup$ – Ivan Beoulve Aug 10 at 0:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.