0
$\begingroup$

I'm rendering a staff with a transparent diamond prism, and everything was working fine until I noticed, while animating, that the crystal was suddenly displaying its texture as though it were opaque. visible in object mode

When I examined the object in edit mode, I noticed that it was invisible. Attempting to select all vertices with "a" and using "alt+h" to see if they were hidden in edit mode did not solve the problem invisible in edit mode

I checked the texture the crystal is bound to just to make sure that it was transparent. transparent texture

What would cause the object to be invisible in edit mode? And why wouldn't it display with its proper opacity?

Here's the blend file: http://www.pasteall.org/blend/30844 imgur album: http://imgur.com/VaxJolX,Lyhvp5k,bRMMApR#2

$\endgroup$
2
$\begingroup$

The crystal mesh is there, but because it's position depends on the armature modifier and the object controlling it, the crystal shows in it's original place when viewed in edit mode. enter image description here

If you enable the modifier in edit mode you should be able to see and edit your object normally.

enter image description here

enter image description here

EDIT

As for transparency, you have not enabled any transparency on the texture or the material:

enter image description here enter image description here

enter image description here

$\endgroup$
  • $\begingroup$ Awesome! Any idea why the texture would be opaque? $\endgroup$ – Stephen Schroeder Aug 6 '14 at 20:08
  • $\begingroup$ @StephenSchroeder , Yes: because none of the controls for transparency are enabled. See edited answer. $\endgroup$ – cegaton Aug 7 '14 at 0:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.