0
$\begingroup$

Trying to export an animated character from Blender 2.8 to Unity 2019.02! I have a few animation done and almost all of them look exactly as they look in blender, except for the Head bone in the action “Attack”, It seems like it gets overly sized when exported to FBX or even when I bake the animation to the deformation bones inside blender, what could be affecting this bone besides the “Head” control to make it this way?

• Scale in blender file was changed to .01 in metric system as recommended for FBX export

• Location, rotation and scale in the Rigify Armature is applied

• I already tried baking animation on the “head” “neck” and “chest” rig controls

enter image description here

enter image description here

First image is how it looks in blender, 2nd is how it shows in Unity.

Now, baking the animation to only the deformation bones messed up the setup for the rest of the animations BUT when I do that I get the same deformation than when exporting to FBX so I know it's something with the Rig setup more than any export setting:

enter image description here

Something extra to say It's that i have to keyframe the "head_Follow" and "neck_follow" setting on rigify at the beggining and end of every action, So I'm assuming that this problem is not there.

What else can I try to have it exported with no weird deformations? Is this a common issue?

$\endgroup$
1
$\begingroup$

I had a similiar Problem with a Quadruped, where Parts of the Animation were completely broken: the Head had a wrong position while the ears were in the right position. Apparently the Parent Child structure of the Deformation Bones is not suited for baking and does not always work correctly outside of Blender.

I solved this with the ORG Bones (Bottom Last Layer) as Deformation Bones instead of the actual Deformation Bones (Bottom Third Last Layer).

Step by Step:

In Edit mode:
- Select all Deformation bones in the Bottom Third Last Layer, go to Armature->Bone Settings->Deform (Hold Alt while clicking the checkbox, so it will untick the deform option for all of these bones)
-Select all Deformation bones in the Bottom Last Layer, go to Armature->Bone Settings->Deform (Hold Alt while clicking the checkbox, so it will tick the deform option for all of these bones)
-Rename the vertex groups so they have the Prefix ORG instead of DEF.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.