1
$\begingroup$

Trying to add an image texture on my mesh, and i UV unwrap it like this. enter image description here but it turns out to be enter image description here Not sure what is wrong with this. Have no clue. Here is my Node setup(i am using backfacing to make a plane have two material on both side) enter image description here

$\endgroup$
1
  • $\begingroup$ Remake a new logo file ,and made it jped file. now it works... $\endgroup$
    – Richard
    Aug 5, 2019 at 0:13

2 Answers 2

1
$\begingroup$

In order to prevent the image repeating, set the Image Texture node from ‘Repeat’ to ‘Clip’. This tells the node to only output a single image within the 0.0 -> 1.0 range.

$\endgroup$
2
  • $\begingroup$ What do you mean by set from Repeat to clip, is there any check box or option?? $\endgroup$
    – Richard
    Aug 5, 2019 at 5:15
  • $\begingroup$ @Richard On the Image Texture node you’ll see the various settings for the node - currently Color, Linear, Flat, Repeat, Single Image. Click on the Repeat one - this sets how the image should behave outside the normal coordinate range - you should see an option for ‘Clip’ - choose that one. $\endgroup$ Aug 5, 2019 at 6:59
0
$\begingroup$

If you check Min and Max in each Vector > Mapping node, then the image will not repeat.

$\endgroup$
3
  • $\begingroup$ Thank you, think this would help many people! $\endgroup$
    – Richard
    Aug 5, 2019 at 3:21
  • $\begingroup$ @Richard Thanks! Glad to help. If you liked my answer, please consider upvoting and accepting it (the up-arrow and check mark on my post’s left-hand side). I’d appreciate it! $\endgroup$
    – Shady Puck
    Aug 5, 2019 at 3:29
  • $\begingroup$ I really appreciate! but i dont have enough reputation to vote... sorry for that $\endgroup$
    – Richard
    Aug 5, 2019 at 5:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .