0
$\begingroup$

I'm trying to create coving/cornices and some skirting boards for a room I'm making. I've created the initial mesh by making a 2D profile and using the extrude and shear tools to follow the edge of the room. I've spent some time cleaning up duplicate vertices and edges, as well as deleting internal faces, but when I apply a subdivision modifier to the mesh, one corner of it appears as expected, but the other three average out and cut the corner like the images below.

enter image description here enter image description here enter image description here

At first I thought it might be because I need to add a loop cut to both sides of each corner, but this hasn't been done on that corner, yet it works fine.

I'm fairly new to Blender, so I'm bound to have done something wrong somewhere here. I'm pretty sure I've cleared up all the duplicate geometry, and I can't see any additional vertices in the working corner (EDIT: I've double checked this by vertex selecting the working corner and comparing the number with a not-working corner, they're the same). Any ideas?

Another edit: I think I've found the problem, but I have no clue how it happened.

In face select mode, I noticed what appeared to be edges that have the centre dot you see on faces.

enter image description here enter image description here

Selecting these and deleting faces doesn't break the mesh, but I have no clue how that happened.

Additional note: Deleted those faces and attempted to apply the subsurf again, but the same problem occurs, so I'm still at a loss on this one.

$\endgroup$
  • $\begingroup$ It could be that you have duplicate vertices at one edge loop. You can remove them, if they exist, by going to edit mode and then in the Vertex menu Vertex > Merge Vertices > By Distance. $\endgroup$ – Robert Gützkow Aug 4 at 16:26
  • $\begingroup$ I did go through and do this when I created the mesh. There were a lot of duplicates, but not anymore. $\endgroup$ – Stuart Wood Aug 4 at 16:32
  • $\begingroup$ You can see in your second new screenshot that you have tiny faces on the inner side. You likely extruded or inserted an edge loop and gave it a bit of an offset enough that merge by distance didn't remove it. $\endgroup$ – Robert Gützkow Aug 4 at 16:44
  • $\begingroup$ It turned out to be a combination of the two actually rjg. I found those tiny faces and deleted those just now, but that didn't make any difference. When I selected vertices again on that corner, there were now twice the number as the other three, so I merged those and now it works as expected. $\endgroup$ – Stuart Wood Aug 4 at 16:46
1
$\begingroup$

After some playing around I've found the problem.

With face select mode enabled, I noticed that each edge had what appeared to be a face on it, shown by the centre dot markers normally seen in face select mode

enter image description here enter image description here

Deleting those faces alone didn't make much difference, but with vertex select mode back on, I found that there were now twice the number of vertices than the other corners. Merging those together with Vertex > Merge Vertices > By Distance solved the issue.

The mesh looks wierd on all four corners now, but that's expected and now I can fix it the normal way.

enter image description here

$\endgroup$
0
$\begingroup$

It does look like you need control cuts on the corners

enter image description here

What happens if you do this?

$\endgroup$
  • $\begingroup$ Yeah I figured that would be the case, but my confusion came from the fact that the corner on the left was sharp even without control cuts. I sorted that (as per my answer above) and created the cuts on each corner after. All looking good now :) $\endgroup$ – Stuart Wood Aug 4 at 17:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.