0
$\begingroup$

I created a cube and made it sort of rectangular. When I tried to UV map it, this is what it looked like:

enter image description here

As you can see in the UV layout, all the faces of the mesh are being represented as squares. I was hoping that the dimension of the faces would be more similar to the actual faces in the mesh, i.e. more rectangular.

Is there something I'm doing wrong?

$\endgroup$
  • 3
    $\begingroup$ Probably the objet is scaled. In object mode, apply the scale. $\endgroup$ – lemon Aug 4 at 14:05
  • $\begingroup$ But that's what I already did. I was in object mode when I made the cube rectangular. And then I went to edit mode to mark the seams. $\endgroup$ – User95 Aug 4 at 14:33
  • $\begingroup$ OK, but in object mode, have you tried using Ctrl+A then 'scale' (apply scale)? $\endgroup$ – lemon Aug 4 at 14:34
  • $\begingroup$ No, I just pressed the N key to open the Transform window. Then I changed the scale value from there. $\endgroup$ – User95 Aug 4 at 15:36
  • $\begingroup$ That's the reason, but you now have a plain answer about it. $\endgroup$ – lemon Aug 4 at 15:38
4
$\begingroup$

Seems like you have edited the object and didn't apply the scaling. If so, you have to apply the changes for your particular editing transformations such as Scaling and Rotating.

  • Go to the Object mode
  • Use ⎈ CtrlA and select an option.

This will apply your transformation changes to the object by setting the Scale to (1,1,1) and Rotation to (0,0,0).

See the documentation

Scaling object and UV Unwrap without applying transformation changes:

enter image description here

After applying changes:

enter image description here

$\endgroup$
  • $\begingroup$ But can't I hit the N key (to open the Transform window) and directly change the scaling from there? Because I actually need precise values. Why is that different from scaling the object by selecting it with A? $\endgroup$ – User95 Aug 4 at 15:38
2
$\begingroup$

A complement to @firat answer which is good (and in response of the question you've added in comments).

When you scale an object, for instance this:

enter image description here

Internally, it keeps the same sizes:

enter image description here

Because internally, vertices positions haven't changed, they are just stretched from the outside.

And in some circumstances this has an impact: this is the case concerning the UV maps (as the UV maps are at vertex level).

Take that as some kind of convention, in order Blender keeps coherency in its behavior.

So here, just apply scale, as described in the main answer.

$\endgroup$
  • 1
    $\begingroup$ Thanks for clearing that up :) $\endgroup$ – User95 Aug 4 at 16:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.