0
$\begingroup$

First time using blender and I'm not very experienced using video editing software either.

I'm trying to preview a video game clip that's 1080p 60fps. The FPS of the preview is around 2-4, and sometimes even lower.

Some PC specs...

CPU: Intel i7-6700

GPU: NVIDA GeFore GTX 970 4GB

I feel like my computer should be able to handle this, so why is my FPS so low? Is there some settings I'm missing? Any help will be appreciated.

Edit: So I learned the videos are actually in 4k, so I changed my resolution to 3840x2160 and that kinda helps with the FPS. It starts out between 20-30, but then drops low and gets laggy. Like the audio plays just fine, but the video skips and seems to get stuck on single frames for awhile.

$\endgroup$
  • $\begingroup$ Blender has a parameter that indicates how much memory it can use. That amount limits the number of frames it can load or prefetch. That could be your problem. You can try to increase User Preferences/System/Memory & Limits/Sequencer cache limit. $\endgroup$ – Kiskit Aug 4 at 6:03
  • $\begingroup$ @Kiskit I changed my Sequencer Cache Limit from 4096 to 32768, and it seemed to help my FPS. However the video is still really laggy. The audio plays just fine, but the video skips and seems to get stuck on single frames for a few seconds at a time. $\endgroup$ – MahiMauler Aug 4 at 6:41
  • $\begingroup$ I don't know if this helps, but are you using CUDA? $\endgroup$ – Kiskit Aug 4 at 7:16
  • $\begingroup$ @Kiskit Under Edit->Preferences->System->Cycles Render Devices->CUDA, I have "GeForce GTX 970 (Display)" checked. $\endgroup$ – MahiMauler Aug 10 at 22:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.