I have no operator preset options (FBX 6.1 ASCII, FBX 7.4 Binary). I had blender 2,79 now 2.80 but no presets appear. That makes it impossible for me to export FBX with textures. I read somewhere that some file needs to be modify somewhere on the computer but it wasn't clear. Any ideas??


The .fbx ASCII format has been removed in Blender 2.8, the remaining export format is the binary format. You should be able to export to the other application just as you did in Blender 2.79, except that in the older version you had to explicitly select the binary format which is now the default in 2.8. The materials need to be setup separately because .fbx can't store Cycles or Eevee materials.

In order to embed texture into the file you have to set the following two options:

  1. Path Mode is Copy
  2. Embed Textures is enabled

enter image description here

Although I haven't personally tested it, you may want to try glTF as export format because it should be able to translate textures and materials to the other software, if you use the principled shader for a PBR setup.

| improve this answer | |
  • $\begingroup$ I don't have format options (not ASCII or any other) is that normal? The other thing I'm not intending to use this in unreal engine but in 3ds max to do Animation. Vertex Paint in 3ds max is a pain in the A**. Blender method is perfect... but not for me because a can't export anything... $\endgroup$ – Ivan Aug 4 '19 at 8:08
  • $\begingroup$ @Ivan Yes as I said the export is in the binary format, because the ASCII option has been removed in Blender 2.8 $\endgroup$ – Robert Gützkow Aug 4 '19 at 8:11
  • $\begingroup$ Ok, then why I can't have textures exported ever? $\endgroup$ – Ivan Aug 4 '19 at 19:23
  • $\begingroup$ @Ivan I've added the relevant export options. $\endgroup$ – Robert Gützkow Aug 4 '19 at 20:42
  • $\begingroup$ Yes I've done that a thousand times, I select copy then select the icon to embed the textures that is on the right side the little box with papers, and then... nothing.... just the fbx without textures. This happened in 2.79 and now in 2.8.. still no solution. $\endgroup$ – Ivan Aug 4 '19 at 20:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.