0
$\begingroup$

I have a planet created in one blender file [A], which I am appending to another blender file [B]. The planet in file A renders beautifuly, while in file B, the render is noisy.

I have checked and can confirm that all Render, Output and View Layer options are set the same in both files. Besides the planet itself, the cameras and lights were also appended, so these should be the same as well.

I am using blender 2.8 & Cycles with both the files, rendering both on GPU. Could anyone give me any hints on what could be causing the difference?

Preview - noisy vs clear render

Source files

$\endgroup$
5
  • $\begingroup$ Is denoising activated in file A (View Layer tab)? $\endgroup$
    – Robert Gützkow
    Aug 3, 2019 at 15:57
  • $\begingroup$ No, it is not, just re-checked and the View Layer tab is configured the same in both files. $\endgroup$
    – Ondrej
    Aug 3, 2019 at 16:00
  • $\begingroup$ We can make so more guesses, but it would probably be better if we could look at the actual two .blend files, if it's possible for you to upload them. $\endgroup$
    – Robert Gützkow
    Aug 3, 2019 at 16:05
  • $\begingroup$ Sure it is :-) Linked in the post above. $\endgroup$
    – Ondrej
    Aug 3, 2019 at 16:34
  • $\begingroup$ I have just also tried doing it the other way around: copying other objects INTO the clean file. Strangely, this also results in the renders from the clear file getting noisy. $\endgroup$
    – Ondrej
    Aug 3, 2019 at 18:03

1 Answer 1

1
$\begingroup$

The reason for the noise are the other lights and objects in the scene that are placed inside the planet. That's probably not where they are supposed to be because they can't be seen, but they have impact on the rendering and cause more noise. If you move them to another scene or exclude them from rendering it will look just like before. If they are supposed to be placed there and remain visible, you will need to increase the render sample to reduce the noise or you could enable denoising in the view layer.

Disable rendering for problematic objects. Restriction toggles Hide from render

Problematic objects Problematic objects

Before Before

After After

$\endgroup$
1
  • $\begingroup$ Aaaand - right you are! Many thanks, this never occured to me. $\endgroup$
    – Ondrej
    Aug 4, 2019 at 7:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .