2
$\begingroup$

I recently opened the first build of 2.8 for Blender and for some reason none of the keyboard keys work, nor the mouse. I can click all the side menus and different buttons but hitting hotkeys does nothing. So I installed Candidate 3 thinking I just needed the new one. Same issue, I did a factory reset in the preferences, I tried uninstalling and reinstalling. I tried using the repair option in the Setup Wizard. Nothing has worked, I can open Blender files and what not but literally no keystrokes register.

If I go into preferences page, when adding a Add-on it says Traceback error. I also go into the Keymap tab thinking maybe I hit something but the tab is completely empty and I can't figure what to do to fix this.enter image description here

If anyone knows the issue, please help because I use Blender to practice to land an Animation job one day and if I can't use it I can't progress.

Error Messages: sorry for the home screen one I barely missed it.enter image description here enter image description here

Ran the debug_log This is a brief summary because it is far too long.

location: :-1

location: :-1 Traceback (most recent call last): File "C:\Program Files\Blender Foundation\Blender\2.80\scripts\modules\bpy\utils__init__.py", line 187, in register_module_call register() File "C:\Program Files\Blender Foundation\Blender\2.80\scripts\startup\bl_operators__init__.py", line 70, in register register_class(cls) ValueError: register_class(...): already registered as a subclass

During handling of the above exception, another exception occurred:

Traceback (most recent call last): File "", line 1, in File "C:\Program Files\Blender Foundation\Blender\2.80\scripts\modules\bpy__init__.py", line 81, in main() File "C:\Program Files\Blender Foundation\Blender\2.80\scripts\modules\bpy__init__.py", line 78, in main utils.load_scripts() File "C:\Program Files\Blender Foundation\Blender\2.80\scripts\modules\bpy\utils__init__.py", line 260, in load_scripts test_register(mod) File "C:\Program Files\Blender Foundation\Blender\2.80\scripts\modules\bpy\utils__init__.py", line 229, in test_register register_module_call(mod) File "C:\Program Files\Blender Foundation\Blender\2.80\scripts\modules\bpy\utils__init__.py", line 189, in register_module_call import traceback

File "C:\Program Files\Blender Foundation\Blender\2.80\python\lib\traceback.py", line 5, in import linecache

File "C:\Program Files\Blender Foundation\Blender\2.80\python\lib\linecache.py", line 11, in import tokenize

File "C:\Program Files\Blender Foundation\Blender\2.80\python\lib\tokenize.py", line 33, in import re File "C:\Program Files\Blender Foundation\Blender\2.80\python\lib\re.py", line 122, in import enum File "C:\Program Files\Blender Foundation\Blender\2.80\python\lib\enum.py", line 2, in from types import MappingProxyType, DynamicClassAttribute ImportError: cannot import name 'MappingProxyType' from 'types' (C:\Users\ahuls\AppData\Roaming\Blender Foundation\Blender\2.80\scripts\addons\types.py)

location: :-1

location: :-1 WARN (wm.keymap): K:\BlenderGit\blender\source\blender\windowmanager\intern\wm_keymap.c:467 WM_keymap_poll: empty keymap 'Grease Pencil'

WARN (wm.keymap): K:\BlenderGit\blender\source\blender\windowmanager\intern\wm_keymap.c:467 WM_keymap_poll: empty keymap 'Grease Pencil Stroke Edit Mode'

WARN (wm.keymap): K:\BlenderGit\blender\source\blender\windowmanager\intern\wm_keymap.c:467 WM_keymap_poll: empty keymap 'Grease Pencil Stroke Paint Mode'

$\endgroup$
  • $\begingroup$ Please add a screenshot of the error messages you are seeing. Please make sure that you're using current graphics driver and that your system fulfills the minimum requirements for Blender 2.8 blender.org/download/requirements $\endgroup$ – rjg Aug 2 at 17:07
  • $\begingroup$ I am updated in both driver and I meet the system requirements, I know this because Blender Beta was working fine prior to it randomly not working. I am still confused why the Keymap tab is empty. $\endgroup$ – Alexander Aug 2 at 17:35
  • 1
    $\begingroup$ Can you try to download the archive version (.zip) of Blender 2.8 and check if that works properly? blender.org/download perhaps something went wrong during install if you had 2.79 previously installed (or in general). $\endgroup$ – rjg Aug 6 at 17:01
  • 1
    $\begingroup$ Can you go to install directory of Blender, type cmd in the address bar, press enter. Then type .\blender.exe --factory-startup. Does it make any difference? It looks there are problems with all python add-ons and their registration. $\endgroup$ – rjg Aug 6 at 17:53
  • 1
    $\begingroup$ I want to thank you rjg for sticking with me this whole time and trying to help I really appreciate it. Also, thank you Blender Blackened for also trying to help. I have been away for a couple days so I am barely seeing this. I do not have enough reputation to go into chat so I apologize for that. $\endgroup$ – Alexander Aug 9 at 16:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.